LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Games (https://www.linuxquestions.org/questions/linux-games-33/)
-   -   Can not fix x-mame since months (https://www.linuxquestions.org/questions/linux-games-33/can-not-fix-x-mame-since-months-136574/)

Harp00 01-19-2004 09:24 PM

Can not fix x-mame since months
 
Hi, i tried everithing in order to make xmame work with Linux, but i think it is not possible if some mamer won't help me.
I downloaded x-mame 0.78.1 and gxmame 0.34b and i followed instructions i found in the README files and in the forum i posted in theese months and also in posts i found on the net, but unsucess!!!!:mad: :( :rolleyes: :cry:
I used the same roms under win XP and everythingh is ok. but if i try to run the same games under Linux only few works

eg (trying to play bobble bobble)

.~$ xmame.x11 bublbobl -rompath "/home/franco/roms/"
info: trying to parse: /usr/local/share/xmame/xmamerc
info: trying to parse: /home/franco/.xmame/xmamerc
info: trying to parse: /usr/local/share/xmame/xmame-x11rc
info: trying to parse: /home/franco/.xmame/xmame-x11rc
info: trying to parse: /usr/local/share/xmame/rc/bublboblrc
info: trying to parse: /home/franco/.xmame/rc/bublboblrc
Mouse/Trakball selected.
loading rom 0: a78-06.51
loading rom 1: a78-05.52
loading rom 2: a78-08.37
loading rom 3: a78-07.46
loading rom 4: 68705.bin
loading rom 5: a78-09.12
loading rom 6: a78-10.13
loading rom 7: a78-11.14
loading rom 8: a78-12.15
loading rom 9: a78-13.16
loading rom 10: a78-14.17
loading rom 11: a78-15.30
loading rom 12: a78-16.31
loading rom 13: a78-17.32
loading rom 14: a78-18.33
loading rom 15: a78-19.34
loading rom 16: a78-20.35
loading rom 17: a71-25.41
done
a78-06.51 NOT FOUND
a78-05.52 NOT FOUND
a78-08.37 NOT FOUND
a78-07.46 NOT FOUND
68705.bin NOT FOUND
a78-09.12 NOT FOUND
a78-10.13 NOT FOUND
a78-11.14 NOT FOUND
a78-12.15 NOT FOUND
a78-13.16 NOT FOUND
a78-14.17 NOT FOUND
a78-15.30 NOT FOUND
a78-16.31 NOT FOUND
a78-17.32 NOT FOUND
a78-18.33 NOT FOUND
a78-19.34 NOT FOUND
a78-20.35 NOT FOUND
a71-25.41 NOT FOUND
ERROR: required files are missing, the game cannot be run.


eg (trying to play one of the few that work)

~$ xmame.x11 outrun -rompath "/home/franco/roms/"
info: trying to parse: /usr/local/share/xmame/xmamerc
info: trying to parse: /home/franco/.xmame/xmamerc
info: trying to parse: /usr/local/share/xmame/xmame-x11rc
info: trying to parse: /home/franco/.xmame/xmame-x11rc
info: trying to parse: /usr/local/share/xmame/rc/outrunrc
info: trying to parse: /home/franco/.xmame/rc/outrunrc
Mouse/Trakball selected.
loading rom 0: 10380a
loading rom 1: 10382a
loading rom 2: 10381a
loading rom 3: 10383a
loading rom 4: 10268
loading rom 5: 10232
loading rom 6: 10267
loading rom 7: 10231
loading rom 8: 10266
loading rom 9: 10230
loading rom 10: 10371
loading rom 11: 10372
loading rom 12: 10373
loading rom 13: 10374
loading rom 14: 10375
loading rom 15: 10376
loading rom 16: 10377
loading rom 17: 10378
loading rom 18: 10187
loading rom 19: 10193
loading rom 20: 10192
loading rom 21: 10191
loading rom 22: 10190
loading rom 23: 10189
loading rom 24: 10188
loading rom 25: 10327a
loading rom 26: 10329a
loading rom 27: 10328a
loading rom 28: 10330a
loading rom 29: 10185
done
Using a Visual with a depth of 24bpp.
MIT-SHM Extension Available. trying to use... Success.
Using Shared Memory Features to speed up
Actual bits per pixel = 32... Ok
Using 16bpp video mode
info: setting fragsize to 1024, numfrags to 5
info: fragsize = 1024, numfrags = 5
info: audiodevice /dev/dsp set to 16bit linear stereo 22050Hz
info: sysdep_dsp: using oss plugin
info: sysdep_mixer: using oss plugin
Average FPS: 60.002457 (63 frames)


I tried different version of xmame and different rom path or xmamerc edit and, as i said, every suggest i found on any forum.

Have i to give up?

Please help me

phulshof 04-15-2004 03:07 AM

Which romfiles do you have in that directory?
 
I'm wondering if you're actually starting the correct bubble bobble game, or if perhaps some of those files are supposed to be in the zipfile of the parent i.s.o. the clone. Could you check which files are in the bublbobl.zip file (unzip -t bublbobl.zip in that directory should do the trick)?

For a tad quicker work on this problem, just email me at phulshof@xs4all.nl, and I'll see if I can help you figure this one out.

Harp00 04-19-2004 02:43 PM

I wrote you back. Did you see my e-mail?

phulshof 04-19-2004 03:34 PM

Quote:

Originally posted by Harp00
I wrote you back. Did you see my e-mail?
I'm afraid not. Could you try again at phulshof@xs4all.nl? I normally at least acknowledge the receiving of an email within 24 hours, and usually answer within that timespan too. Perhaps your email was caught in the virus/spam filters of my provider; I'll look into that.

phulshof 04-19-2004 03:49 PM

Yep, caught by the spamfilter
 
Ok, I just found your email in my spambox. It appears your ISP is blacklisted, which caused your email to end up in the spambox of my provider. I'll email you as soon as I've read it, and I'll check my spambox from time to time to see if any messages ended up in there that shouldn't have.

repeater75 05-31-2004 11:08 PM

This kinda sucks cuz the rest of us don't benefit from the eventual fix provided and others (yeah, you guessed it, its me) have the same issues...

phulshof 05-31-2004 11:46 PM

Solutions
 
Quote:

Originally posted by repeater75
This kinda sucks cuz the rest of us don't benefit from the eventual fix provided and others (yeah, you guessed it, its me) have the same issues...
Well, usually these problems are very user specific, and answers are of little use to other users, but perhaps this one will help you. Here is the answer I sent through email:

> Anyway, your problem with bublbobl: From the output of xmame, and unzip I
> understand that you have an old version of the romfiles on your system.
> When a new version of MAME comes out, sometimes the romfiles have been
> updated, and you have to get the newer roms to make them work. You'd have
> the same problem if you upgraded to the latest windows version of MAME.

Regards,

Pieter Hulshoff

mtb 06-01-2004 02:38 AM

Re: Can not fix x-mame since months
 
Quote:

Originally posted by Harp00
Hi, i tried everithing in order to make xmame work with Linux, but i think it is not possible if some mamer won't help me.
I downloaded x-mame 0.78.1 and gxmame 0.34b and i followed instructions i found in the README files and in the forum i posted in theese months and also in posts i found on the net, but unsucess!!!!:mad: :( :rolleyes: :cry:
I used the same roms under win XP and everythingh is ok. but if i try to run the same games under Linux only few works

eg (trying to play bobble bobble)

.~$ xmame.x11 bublbobl -rompath "/home/franco/roms/"

Try xmame.x11 /home/franco/roms/bublbobl.zip ( or what is, absolute path + rom name ). I know it seems stupid but iirc there is a problem with the rompath.

Also: are you sure that the windows version of xmame is the same? Roms are different sometimes, new xmame= new roms or they don't work in some cases.


All times are GMT -5. The time now is 02:38 PM.