LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games
User Name
Password
Linux - Games This forum is for all discussion relating to gaming in Linux.

Notices


Reply
  Search this Thread
Old 08-13-2020, 02:54 PM   #1
burning
Member
 
Registered: Jan 2020
Location: Canada
Distribution: Slackware
Posts: 216

Rep: Reputation: Disabled
Armagetronad not starting on Slackware Linux


Hi, I'm running Slackware linux on a 32-bit laptop and just installed the Armagetronad SlackBuild, including all its dependencies using sbopkg. But in trying to run armagetronad or armagetronad-master, neither seem to launch and nothing happens. Any idea what the problem could be?
I just tried running it from terminal inside of an Xsession from /usr/games where its stored and listed as an executable.

it returned the following output:
Code:
Error: Error in tString GeneratePrefix() in tools/tDirectories.cpp:1359 : 
Relocation error. The binary was supposed to be installed into /usr/games and found itself in  and could not find out what this means for
the prefix /usr.
The weird thing is, it is in /usr/games I see it right there, it doesn't seem to recognize where it's located though.
 
Old 08-13-2020, 05:16 PM   #2
boughtonp
Member
 
Registered: Feb 2007
Location: UK
Distribution: Debian
Posts: 558

Rep: Reputation: 365Reputation: 365Reputation: 365Reputation: 365
Searching for "Error in tString GeneratePrefix() in tools/tDirectories.cpp" returns a couple of results that may contain useful info...

https://www.linuxquestions.org/quest...ld-dir-552117/
https://forums3.armagetronad.net/viewtopic.php?t=36797

If you're not building from source, and you have the latest version, then you may want to raise a bug report.

 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
When Centos 6.3 starting,All services starting OK and starting Atd: OK .And stop scr. DeSouffle Linux - General 4 08-29-2013 12:46 AM
[testing] armagetronad slackbuild - the real tron cycles ponce Slackware 4 12-20-2010 03:17 PM
[SOLVED] Starting File System .. Starting File System .. Starting File System .. Starting File rmknox Linux - Newbie 3 08-15-2010 11:30 PM
Starting apps after starting xfce?? gtgoku Slackware 2 08-21-2004 01:49 PM
starting kpppd w/ ximian or starting ximian w/ kde ergo_sum Linux - Newbie 8 12-02-2003 05:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software > Linux - Games

All times are GMT -5. The time now is 01:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration