-   Linux - Games (
-   -   Americas Army: Xlib problem, looking for a to the point answer (

rusty0412 01-09-2004 07:34 AM

Americas Army: Xlib problem, looking for a to the point answer

I just installed America's Army 2.0.0a on my Fedora Core, kernel 2.6.0 box. I know you have had this question, but I am looking from an answer of somebody who has solved this problem and to the point. I can't run AA, if I run armyops the logo will show up, it gos to a lower resolution and it crashes. I am away from my Linux computer right now, but error output contains this:

Xlib: extension "XFree86-DRI" missing on display ":0.0".

I am running a NVIDIA 1.0-4496 driver with a GeForce4 MX 440.
Any help is greatly appreciated.

trey85stang 01-09-2004 03:19 PM

did you compile DRI into your kernel? there messages indicates your do not have DRI

rusty0412 01-09-2004 04:36 PM

Isn't that supposed to be in XFree not in the kernel?

trey85stang 01-09-2004 05:52 PM

I know for a fact on 2.6.0 it has to be compiled into the kernel, dont know about previous kernel's though.

I had the same thing after i upgraded to 2.6.0, went back and enabled DRI.. and was back in action.

rusty0412 01-09-2004 06:58 PM

Hmmm, now I have a good reason why to compile the new 2.6.1 kernel :)

LavaDevil94 01-09-2004 09:15 PM

thanks for the warning, even though i dont use DRI :).

rusty0412 01-11-2004 10:13 PM

Ok i compiled 2.6.1 kernel with DRI support but I get the same error. I now remember I have always gotten Xlib: extension "XFree86-DRI" missing on display ":0.0" on some screensavers.The full error of America's Army is:
Xlib: extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0".
Xlib: extension "XFree86-DRI" missing on display ":0.0".
GL_EXT_bgra not supported - bailing out.


Exiting due to error

trey85stang 01-12-2004 08:42 PM

are you having problems with any other 3d apps?

shadowhunter 01-13-2004 01:43 PM

try running as root. Maybe your dri-previleges aren't set up.


SniperDevil 01-13-2004 04:17 PM

I use an older kernel, however AA still works with WineX for me.... odd..

rusty0412 01-13-2004 04:19 PM

I tried as root. SniperDevil: Why do you use WineX to run AA when there is a native Linux version?

SniperDevil 01-13-2004 04:24 PM

I use WineX because I use it for everything else, and it was fairly simple to configure.

r_jensen11 01-19-2004 10:08 AM

have you checked your xfree86 file? There should be an option for DRI near the bottom of the file. It should be right next to an opengl option, if I remember properly.

rusty0412 01-19-2004 04:30 PM

I fixed it by removing the libGL from XFree because it was conflicting with NVIDIA's one.

LinuxBAH 01-30-2004 09:48 PM

I take it your not too fond of reading the documentation that comes with things you install? If you read the README file for your nvidia drivers they state you need to modify your XF86Config file, edit your nvidia driver which is named "nv" and rename it to "nvidia" Also you will need to comment out Load Dri and make sure that Load GLX is uncommented. :) I dunno why you'd want to use Dri.

All times are GMT -5. The time now is 04:15 PM.