-   Linux From Scratch (
-   -   XRANDR configuration error (

pannet1 04-06-2012 07:33 AM

XRANDR configuration error
Dear LFS users,
while installing Xrandr package i got the following error. I hope any one send solution for the following error.

root@Laughlin [ ~/xc/app/xrandr-1.3.5 ]# ./configure $XORG_CONFIG
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for style of include used by make... GNU
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking for gcc option to accept ISO C99... -std=gnu99
checking how to run the C preprocessor... gcc -std=gnu99 -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking whether __clang__ is declared... no
checking whether __INTEL_COMPILER is declared... no
checking whether __SUNPRO_C is declared... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for a sed that does not truncate output... /bin/sed
checking if gcc -std=gnu99 supports -Werror=attributes... no
checking for floor in -lm... yes
checking for XRANDR... configure: error: Package requirements (xrandr >= 1.3 xrender x11 xproto >= 7.0.17) were not met:

No package 'xrandr' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables XRANDR_CFLAGS
and XRANDR_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


druuna 04-06-2012 08:59 AM


xrandr is installed when doing the Xorg Applications chapter, is that what you are doing? If so: Did the installation of the Xorg Libraries go as expected (it contains libXrandr.{so,a}, libXrender.{so,a} and libX11.{so,a}).

Hope this helps.

BTW: Are you still using the chrooted method?

pannet1 04-06-2012 09:47 AM

Dear druuna,
Yes we are still using chroot environment to install graphical packages is that anything wroung.

druuna 04-06-2012 10:14 AM


Originally Posted by pannet1 (Post 4646462)
Yes we are still using chroot environment to install graphical packages is that anything wroung.

Mentioned that in your other post: Solution for Mesa installation error


Originally Posted by druuna
One of the problems you encounter when using the chrooted environment is that the host's kernel and /dev/ entries are used and _not_ those belonging to your freshly build LFS.

Things might work now, but probably won't once you start using your newly build LFS/BLFS system (different kernel, and possibly /dev/ entries).

Besides that, what's the point of having a lean and mean LFS installed and not letting it do all the work....

stoat 04-06-2012 10:29 PM

Hello everybody,

druuna's advice about not building the BLFS system in chroot is universally considered good advice. But that may not be involved in your current issue.

IMO, when the error says something is missing, it's a good indication that something was skipped. Anyway, it happens all the time.

Next, why not script the commands for those Xorg groups like the book suggests? The example shown for the proto group in the Xorg introduction can be modified easily for the other groups. I've never had those scripts error out, and I think I would go barking mad doing all that mindlessly repetitive Xorg stuff manually.

Next, are you sure you are properly chroot-ed and not working at the host system's command prompt?

Anyway, to me the worst thing about building BLFS while chroot-ed is not that it won't work. It does. Or, at least it can. I've done it several times up through X and then finished building in the native system. Those systems worked perfectly. My greatest concern building that way has been that I might get careless, screw up, and install stuff in the host system.

pannet1 04-08-2012 02:20 AM

Dear LFS users,
Solutions for Xrandr configuration is, to install the libX11, libXrender, libXrandr packages correctly, during libXrandr package installation the libraries files are not installed correctly, so we copied the library files from source directory to /usr/X11/lib now every thing is ok and Xrandr package was installed properly.Problem solved thanks to Druuna, stoat for immediate support. We hope,your support will continue in future.

Thanks & Regards,

All times are GMT -5. The time now is 04:04 AM.