-   Linux From Scratch (
-   -   Wireless PCMCIA card driver loading (

ph73nt 04-22-2006 05:34 PM

Wireless PCMCIA card driver loading
Hi folks, some help would be appreciated.

I'm building LFS 6.1.1 on a Paceblade Pacebook Tablet PC. I has a built in REALTEK 10/100 ethernet card and I have a Netgear MA401 PCMCIA wireless LAN card.

As far as I can tell I've enabled all of the hotplug, PCMCIA and wireless options in the kernel. How do I get the card recognised and the driver loaded?

Here is the output of lspci:

00:00.0 Host bridge: Transmeta Corporation LongRun Northbridge (rev 01)
00:00.1 RAM memory: Transmeta Corporation SDRAM controller
00:00.2 RAM memory: Transmeta Corporation BIOS scratchpad
00:03.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:04.0 FireWire (IEEE 1394): Lucent Microelectronics FW323 (rev 04)
00:05.0 CardBus bridge: Texas Instruments PCI1410 PC card Cardbus Controller (rev 02)
00:06.0 VGA compatible controller: Silicon Motion, Inc. SM720 Lynx3DM (rev b1)
00:07.0 ISA bridge: ALi Corporation M1533 PCI to ISA Bridge [Aladdin IV]
00:08.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link Controller Audio Device (rev 01)
00:0f.0 IDE interface: ALi Corporation M5229 IDE (rev c3)
00:11.0 Bridge: ALi Corporation M7101 PMU
00:14.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)

Any thoughts?

comprookie2000 04-22-2006 10:06 PM

I think that card uses the orinoco kernel modules.
See if you have them.
if not
modprobe orinoco
modprobe orinoco-cs
see if the interface shows up
ifconfig -a
I you don't you will have to redo your kernel
to check look at /usr/src/linux/.config
or this may work
cat /usr/src/linux/.config | grep HERMES
my grep skills need some work
This may help

beagle2 04-23-2006 01:30 AM

If you have the MA401RA it uses the prism chipsets -

ph73nt 04-23-2006 04:30 AM

It's definately orinoco as this is what my old distro used. As for modprobe I don't have a modular kernel (I followed the book which recommended not doing it). I'd best build a modular kernel.......

comprookie2000 04-23-2006 11:25 AM

Just add the orinoco stuff as modules, I use the same kernel
cd /usr/src/linux
make menuconfig
add the modules "m"
make && make modules_install

ph73nt 05-04-2006 02:24 PM

No luck yet. Wireless bits and bobs are now modular. I have instaled pcmcia utilities (which includes a startup script).

During startup the text tells me that there is indeed a card inserted into slot 0.

I have created a modules.conf file and inserted the line:
alias eth1 orinoco_cs

Is that valid for LFS?

After boot I do modprobe orinoco_cs and lsmod shows YENTA SOCKET modules and orinoco modules are loaded.

But iwconfig gives:
lo no wireless extensions
eth0 no wireless extensions
eth1 no wireless extensions


Desperate for some help here. Thanks.

comprookie2000 05-05-2006 11:05 PM

Do you have a config file for pcmcia
I don't know where it would be mayby
this may help or ask this guy;

ph73nt 05-07-2006 04:27 AM

I read the link and tweaked the kernel a bit but still nothing.

Regadless of whether I plug in afterboot or before boot I get
file /proc/net/wireless : blank file

when viewing the file with less or cat there is only a header row.


ph73nt 05-24-2006 03:38 AM

Problem solved....

Upgraded udev to version 0.91 and used the init scripts from development version (SVN 20060514). This has solved the problem and the wireless card is now detected correctly. :) reveal another problem

It has, however, introduced a startup error: init_udevd_socket: bind failed
There are thousands of reports of this error with various versions of udev. He we go again!

If it was easy it wouldn't be any fun ;)

All times are GMT -5. The time now is 06:13 PM.