LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices


Reply
  Search this Thread
Old 06-29-2010, 03:56 AM   #1
charlie_lab
Member
 
Registered: Nov 2006
Posts: 255

Rep: Reputation: 30
which install problem


Hello,

I need which so I can work with the slackware package system.
So I downloaded the source.
Did ./configure --prefix=tools
Everything went well

After that I did make and now ar can't be found.
But the configure could find ar.
Code:
checking for ar... x86_64-unknown-linux-gnu-ar
Error message from make.
Code:
make  all-recursive
make[1]: Entering directory `/sources/which-2.20'
Making all in tilde
make[2]: Entering directory `/sources/which-2.20/tilde'
rm -f libtilde.a
x86_64-unknown-linux-gnu-ar cru libtilde.a tilde.o shell.o 
make[2]: x86_64-unknown-linux-gnu-ar: Command not found
make[2]: *** [libtilde.a] Error 127
make[2]: Leaving directory `/sources/which-2.20/tilde'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/sources/which-2.20'
make: *** [all] Error 2
How is it possible that configure can and make can't find a file ??

Roelof

Edit : I do this steps in a chrooted enviroment.

Last edited by charlie_lab; 06-29-2010 at 06:24 AM.
 
Old 06-30-2010, 08:20 AM   #2
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
When I grep through my buildlogs, the only mention I have of x86_64-unknown-linux-gnu-ar is for binutils and gcc, which suggests that you're trying to install which before gcc. Might I suggest that you install which into /tools in chapter 5? Then the binary should be available from the start of chapter 6 and you can reinstall it into /usr/bin later.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Yum Install flvtool2 (and ruby install) Problem athomas Linux - Server 1 10-01-2009 07:04 PM
Slack 11 install problem (cd install asks for /dev/fd0) cygnus-x1 Slackware 1 10-16-2006 11:30 AM
Sound Card problem(every time i install linux i have diffirent hardware problem) jacka1l Linux - Newbie 7 08-11-2005 07:10 AM
Slack 10.1 Install Problem(During Package Install) terdbird Slackware - Installation 2 04-22-2005 03:18 PM
dhcp problem in Debian netinst install..Help !! install. copter Linux - Networking 11 06-30-2004 02:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch

All times are GMT -5. The time now is 04:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration