LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices


Reply
  Search this Thread
Old 10-22-2015, 08:36 PM   #1
stoat
Member
 
Registered: May 2007
Distribution: LFS
Posts: 618

Rep: Reputation: 183Reputation: 183
VLC and corrupt Lua module errors


Re: The current BLFS SVN book versions...
VLC-2.2.1
Lua-5.3.1
I started a video with VLC in a terminal and saw the following error messages in the terminal after VLC started playing the video.
Code:
VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
[09c77648] core demux meta error: corrupt module: /usr/lib/vlc/plugins/lua/liblua_plugin.so
[09bdb9a8] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[b6d00c40] core art finder error: corrupt module: /usr/lib/vlc/plugins/lua/liblua_plugin.so
[b6d03098] core art finder error: corrupt module: /usr/lib/vlc/plugins/lua/liblua_plugin.so
[b44d9520] core generic error: corrupt module: /usr/lib/vlc/plugins/lua/liblua_plugin.so
[09c61148] qt4 interface error: Unable to load extensions module
[b5400718] core art finder error: corrupt module: /usr/lib/vlc/plugins/lua/liblua_plugin.so
[b5400600] core art finder error: corrupt module: /usr/lib/vlc/plugins/lua/liblua_plugin.so
[09ed5fc0] core demux meta error: corrupt module: /usr/lib/vlc/plugins/lua/liblua_plugin.so
[09df7678] avcodec decoder: Using G3DVL VDPAU Driver Shared Library version 1.0 for hardware decoding.
Recompiling Lua-5.3.1 with 5.1 compatibility enabled instead of the default 5.2 resolved all of that stuff. And so far, VLC continues to function normally.
Code:
VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
[081f39a8] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[b5636d00] avcodec decoder: Using G3DVL VDPAU Driver Shared Library version 1.0 for hardware decoding.
I guess this is a VLC issue that will have to be fixed soon since the Lua manual says all of the compatibility modes are to be removed in a future version of Lua. Anyway, JFYI.

References:
https://bugs.archlinux.org/task/44946
http://www.lua.org/manual/5.2/manual.html

Last edited by stoat; 10-23-2015 at 08:36 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Getting VLC add ons written in lua to work ajohn Linux - Software 1 08-27-2013 04:42 AM
[SOLVED] vlc 1.1.0rc2 and avidemux 2.5.3 errors. slackd Slackware 7 06-09-2010 07:25 AM
vlc errors in 10.3 swampdog2002 SUSE / openSUSE 4 10-12-2007 10:10 PM
VLC - Mux/Demuxer errors trek413 Linux - Software 2 10-13-2006 04:07 PM
Errors on Compiling Lua and other programs. Dralnu Linux - Software 1 04-19-2006 01:42 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch

All times are GMT -5. The time now is 07:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration