LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices


Reply
  Search this Thread
Old 10-13-2002, 08:50 AM   #1
peeples
Member
 
Registered: Sep 2002
Location: Wichita Falls, TX
Distribution: tried a lot of 'em, now using kubuntu
Posts: 180

Rep: Reputation: 30
unzipping: file size limit exceeded


I'm doing LFS this weekend. /dev/hda2 was about 30 Gb, so I used parted to shrink it for some extended partitions (/dev/hda5 @ 5Gb and /dev/hda6 @ 5Gb). When I am using bunzip2 to unzip some large .bz2 files (like linux kernel or gcc) I get an error "File size limit exceeded". I have figured out that if I ctrl-alt-F2 and log in as root, that I am able to unzip the file. So root does not have these restrictions.

I'll bet this is the reason I couldn't download some iso's the other day. I was trying to put them on one of these extended partitions. Everytime the download got to 102.4 Mb, gFTP would quit downloading and the program would close itself.

Where do I go to change this limit? Searches on Google brought up a lot of people having this problem using mk2fs, but their cures were patches to files (I don't really understand how to use those).

TIA

denny peeples
 
Old 10-13-2002, 10:57 AM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,696

Rep: Reputation: 232Reputation: 232Reputation: 232
Do you have quota installed?
 
Old 10-13-2002, 11:37 AM   #3
peeples
Member
 
Registered: Sep 2002
Location: Wichita Falls, TX
Distribution: tried a lot of 'em, now using kubuntu
Posts: 180

Original Poster
Rep: Reputation: 30
I went into root account and typed "quota" and got the response that root had no limits (or something to that effect). If this is the problem, how do I turn quota's off? I am the only user on this PC, and I don't need it.

denny
 
Old 10-13-2002, 01:28 PM   #4
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,696

Rep: Reputation: 232Reputation: 232Reputation: 232
Log as your normal user and type
quota -v
If you get something (not error message) please post it here.
 
Old 10-13-2002, 02:25 PM   #5
lfslinux
LFS Maintainer
 
Registered: Jan 2002
Location: Canmore, Alberta, Canada
Distribution: Linux From Scratch
Posts: 372

Rep: Reputation: 30
If not quota's, it could be a Bash imposed limit. Run this command: ulimit -a

Look if you have a limit for the "File size" - this is the maximum size of files you are allowed to create.

See the bash man page how you can change this.
 
Old 10-13-2002, 03:50 PM   #6
peeples
Member
 
Registered: Sep 2002
Location: Wichita Falls, TX
Distribution: tried a lot of 'em, now using kubuntu
Posts: 180

Original Poster
Rep: Reputation: 30
peeples @ /home/peeples >> What do YOU want ?!?
quota -v
Disk quotas for user peeples (uid 506): none

ulimit -a
core file size (blocks, -c) 0
data seg size (kbytes, -d) unlimited
file size (blocks, -f) 100000
max locked memory (kbytes, -l) unlimited
max memory size (kbytes, -m) unlimited
open files (-n) 1024
pipe size (512 bytes, -p) 8
stack size (kbytes, -s) 8192
cpu time (seconds, -t) unlimited
max user processes (-u) 1024
virtual memory (kbytes, -v) unlimited

SO, I guess it's a limit imposed by bash. Going to do some research on Google right now...

dbp
 
Old 10-14-2002, 03:10 AM   #7
adam_boz
Member
 
Registered: Jul 2002
Location: Santa Cruz, CA
Distribution: lfs
Posts: 538

Rep: Reputation: 30
interesting...

I've never seen this problem... kindof interesting though.

I looked through "man bash" and found this:

ulimit [-SHacdflmnpstuv [limit]]
Provides control over the resources available to
the shell and to processes started by it, on sys-
tems that allow such control.
(later)

If limit is given, it is the new value of the spec-
ified resource (the -a option is display only). If
no option is given, then -f is assumed.

-f The maximum size of files created by the
shell

so it looks like maybe you should get rid of "ulimit -<whatever>" from your $HOME/.bash_profile or $HOME/.bashrc

I think that may do the job....

good luck
 
Old 10-14-2002, 08:20 AM   #8
peeples
Member
 
Registered: Sep 2002
Location: Wichita Falls, TX
Distribution: tried a lot of 'em, now using kubuntu
Posts: 180

Original Poster
Rep: Reputation: 30
I went into $HOME/.bash_profile and added a line:
ulimit -f unlimited

Next login, I got a "You don't have permission to do that" kinda answer. SO, I put :
sudo ulimit -f unlimited

(I'm already set up in sudoers). Then I got a "sudo: ulimit: File or directory not found".

Then, I decided to put it in /etc/profile instead of my .bash_profile (that way ALL logins would have the new limit), but I got the same results. I must be doing something wrong. BTW, I did a "locate ulimit", and only found 2 header files(*.h) and 2 man pages, so I did updatedb, tried again, same result. So, I can't even find the offending program...

I REALLY love my new LFS. It is way faster than RH7.3 to get to the CLI login. Plus I learned so much, I think I might have to be inducted into the "guru" clan soon... (I think the more I learn, the more I realize that I have even more to learn...)
 
Old 10-14-2002, 02:39 PM   #9
adam_boz
Member
 
Registered: Jul 2002
Location: Santa Cruz, CA
Distribution: lfs
Posts: 538

Rep: Reputation: 30
I don't know what you should do... the only thing I can say is that when I did "man ulimit" it gave me info on the header file, but it said it was outdated. If you do "man bash" way down there you'll find it.

I was wondering where it would be set... it seems to me that if you put it in ~/.bash_profile or something, that the user would be able to change it.... kindof goes against what it's used for?
 
Old 10-15-2002, 07:17 AM   #10
peeples
Member
 
Registered: Sep 2002
Location: Wichita Falls, TX
Distribution: tried a lot of 'em, now using kubuntu
Posts: 180

Original Poster
Rep: Reputation: 30
SOLVED: file size limit exceeded

I figured it out!!! I had installed a program that "helps" with security called Bastille. It asks a whole bunch of questions and then changes your system to make it more secure. One of the questions had to do with limiting user abilities. I turned off Bastille and everything is fixed now. SO, users beware. I'll rerun the setup program later, and answer the question differently...

Thanks everybody for the help.

Last edited by peeples; 10-15-2002 at 12:30 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
File size limit exceeded XaViaR Linux - General 4 09-21-2005 10:02 PM
file size limit exceeded squid... mchitrakar Linux - Software 2 10-13-2004 01:18 PM
file size limit exceeded mchitrakar Linux - General 2 10-12-2004 12:47 PM
File size limit exceeded npuetz Linux - General 5 10-06-2004 07:34 AM
File size limit exceeded... Faeroon Linux - General 20 01-02-2003 06:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch

All times are GMT -5. The time now is 11:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration