-   Linux From Scratch (
-   -   udev version help??? (

spiky0011 10-07-2012 10:05 AM

udev version help???

Installation of cups

I,m installing colord error

configure: error: Package requirements (gudev-1.0) were not met:

No package 'gudev-1.0' found

udev-extras (from systemd) (for GUdev) is only recommended so not installed.

Ok so i,ll install which gets me

here I have udev 173 installed
There are 2 links to download udev extras this link dosn't give for udev 173.
Neither dose

Any ideas how to get round this?
Do I have to install Udev extras is there away around it?
maybe --disable-gudev ??

spiky0011 10-07-2012 11:32 AM


Google got me thisSo am I correct in thinking this is what I need?
Although the link is down

druuna 10-07-2012 11:48 AM

Is version 173 actually required or can (should?) 188-3 or 193 be used? Both are present in

Never mind, it should be the one you used when installing LFS.... Sorry I wasted your time!

spiky0011 10-07-2012 12:29 PM


I managed to find udev173 buried on a harddrive on the server. So now I can proceed,
Just a note, maybe ther should be a note to save the udev you build LFS with as it took quite awhile to find the 1 I used

spiky0011 10-09-2012 02:30 PM


I have a problem that has arisen from I think from This
When I run startxfce4 the desktop starts, and when I start terminator or xterm I get UNABLE TO START /BIN?BASH. I have put the problem down to devpts not mounting at /dev/pts.
Before i started installing this it worked ok???
To temporary fix before I start xfce I run

sudo mkdir -v /dev/pts

sudo mount -vt devpts devpts /dev/pts
on reboot it's back to not working.
How do I fix this???


/dev/sdc1      /            ext4  defaults        1    1
/dev/sdc2      swap        swap  pri=1          0    0
/dev/sdc5      /home/spiky/Spiky        ext4  defaults        0    2
proc          /proc        proc  defaults        0    0
sysfs          /sys        sysfs  defaults        0    0
devpts        /dev/pts    devpts gid=4,mode=620  0    0
tmpfs          /run        tmpfs  defaults        0    0
# End /etc/fstab

Part of boot.log as highlighted the failure

Oct 07 19:35:23 +01:00 Planet-Spike Recording existing mounts in /etc/mtab... OK
Oct 07 19:35:23 +01:00 Planet-Spike Mounting remaining file systems... OK
Oct 07 19:35:24 +01:00 Planet-Spike Cleaning file systems:
/tmp OK
Oct 07 19:35:24 +01:00 Planet-Spike Retrying failed uevents, if any...
Oct 07 19:35:24 +01:00 Planet-Spike Setting system clock... OK
Oct 07 19:35:25 +01:00 Planet-Spike Setting up Linux console... OK
Oct 07 19:35:25 +01:00 Planet-Spike Starting system log daemon... OK
Oct 07 19:35:25 +01:00 Planet-Spike Starting kernel log daemon... OK
Starting the D-Bus Messagebus Daemon...
[ OK ]
Oct 07 19:35:25 +01:00 Planet-Spike Bringing up the eth0 interface...
Oct 07 19:35:26 +01:00 Planet-Spike Adding IPv4 address to the eth0 interface... OK
Oct 07 19:35:26 +01:00 Planet-Spike Setting up default gateway... OK
Starting the Avahi daemon...
Starting the Avahi mDNS/DNS-SD Server Conf. Daemon...
Oct 07 19:35:26 +01:00 Planet-Spike Initializing kernel random number generator... OK
Oct 07 19:35:26 +01:00 Planet-Spike Starting SSH Server... OK
Starting gpm...
[ OK ]
Oct 08 22:37:17 +01:00 (none) Mounting virtual file systems: /run /proc /sys OK
Oct 08 22:37:17 +01:00 (none) Setting the console log level to 7... OK
Oct 08 22:37:18 +01:00 (none) Bringing up the loopback interface... OK
Oct 08 22:37:18 +01:00 (none) Setting hostname to Planet-Spike... OK
Oct 08 22:37:18 +01:00 Planet-Spike Populating /dev with device nodes...
Oct 08 22:37:18 +01:00 Planet-Spike Setting system clock... OK
Oct 08 21:37:21 +01:00 Planet-Spike Activating all swap files/partitions... OK
Oct 08 21:37:21 +01:00 Planet-Spike Mounting root file system in read-only mode... OK
Oct 08 21:37:21 +01:00 Planet-Spike Checking file systems... OK
Oct 08 21:37:25 +01:00 Planet-Spike Remounting root file system in read-write mode... OK
Oct 08 21:37:25 +01:00 Planet-Spike Recording existing mounts in /etc/mtab... OK
Oct 08 21:37:25 +01:00 Planet-Spike Mounting remaining file systems...FAIL
Oct 08 21:37:25 +01:00 Planet-Spike Cleaning file systems:
/tmp OK

Keith Hedger 10-12-2012 02:27 PM

What does

ls /lib/udev/devices/
I had similar problems, if you look at /etc/rc.d/init.d/udev you will see that you need to set up certain static entry's for udev to populate.

spiky0011 10-12-2012 02:40 PM

Hi Keith

I have pts empty dir and a file null which is empty, I am looking at reinstalling udev but not sure which way to go

Keith Hedger 10-12-2012 02:56 PM

well the pts folder should be being populated what about the kernel config you should have this CONFIG_DEVPTS_MULTIPLE_INSTANCES=y in your config.

spiky0011 10-12-2012 03:02 PM

I have not touched the kernel it was all working ok until the udev install from blfs, The new Blfs instructions are a bit confusing. Or should I just install udev latest?

Keith Hedger 10-12-2012 03:30 PM

Isn't there a bit about using the same udev that you used to build LFS?

spiky0011 10-12-2012 03:43 PM

Yes thats why it confusing. I ran the udev from the old blfs thats when it went wrong.

spiky0011 10-13-2012 01:57 AM


Ok FYI I reinstalled udev-173 which corrected /dev/pts dir problem. I then ran the udev from blfs/svn which broke udev again?? but it dose leave the gudev file which was required.
A reinstall of udev-173 which fixes /devpts dir. This then satisfise colord package.

All times are GMT -5. The time now is 04:14 AM.