-   Linux From Scratch (
-   -   udev install error chapter 6 (

vmlinuz101 03-22-2005 12:12 PM

udev install error chapter 6
hi guys, i'm getting the following error with udev-030 in LFS 6.0
chapter 6.57

root:/sources/udev-030# make udevdir=/dev install
/usr/bin/install -c -d /etc/udev/rules.d
/usr/bin/install -c -d /etc/udev/permissions.d
/usr/bin/install -c -m 644 -D udev.8 /usr/share/man/man8/udev.8
/usr/bin/install -c -m 644 -D udevinfo.8 /usr/share/man/man8/udevinfo.8
/usr/bin/install -c -m 644 -D udevtest.8 /usr/share/man/man8/udevtest.8
/usr/bin/install -c -m 644 -D udevstart.8
/usr/bin/install -c -m 644 -D udevd.8 /usr/share/man/man8/udevd.8
ln -f -s udevd.8 /usr/share/man/man8/udevsend.8
/usr/bin/install -c -d /etc/dev.d/default
/usr/bin/install -c -D etc/dev.d/net/
/usr/bin/install -c -d /dev
/usr/bin/install -c -d /etc/hotplug.d/default
/usr/bin/install -c -D udev /sbin/udev
/usr/bin/install -c -D udevd /sbin/udevd
/usr/bin/install -c -D udevsend /sbin/udevsend
/usr/bin/install -c -D udevinfo /usr/bin/udevinfo
/usr/bin/install -c -D udevtest /usr/bin/udevtest
/usr/bin/install -c -D udevstart /sbin/udevstart
ln -f -s /sbin/udevsend /etc/hotplug.d/default/udev.hotplug
killall udevd
udevd: no process killed
make: [install] Error 1 (ignored)
rm -f /dev/.udev.tdb

do i have to nuke my whole lfs partition, or is there anything that'll
save it?



Oliv' 03-23-2005 09:03 AM



do i have to nuke my whole lfs partition
no... I even think that you can go to the next step ;)
'cause all udev exec have been installed, symbolic links done and that's when it try to kill an hypothetic old udev daemon (probably to restart the new one) that it fails. So I think that's OK for the next step ;)

caffeinebot 08-27-2005 05:17 AM

One step later..
I got the same error, however, i can't even do the following command as described in the book.

cp ../udev-config-3.rules /etc/udev/rules.d/25-lfs.rules
theres no such file in the directory below my source directory..
any clues?

CCMCornell 09-18-2005 11:18 PM

Re: One step later..

Originally posted by caffeinebot

cp ../udev-config-3.rules /etc/udev/rules.d/25-lfs.rules
theres no such file in the directory below my source directory..
any clues?

I stumbled across this post while googling for a different udev LFS install error. I realize this post is a little old and you may have already solved the problem, but just for reference, the rules file was supplied by LFS to replace the default rules that normally comes with the udev source, so it's not in the source tree.

I'm building from the LFS 6.1 Live CD, so it was already included with the other sources and patches. The URL for the rules file is listed just after the URL for the udev source tarball in section 3.2.

Section 3.2:

The LFS 6.1 udev config rules file:

All times are GMT -5. The time now is 12:11 AM.