-   Linux From Scratch (
-   -   suggest version for LFS (

priya001 05-25-2006 08:58 AM

suggest version for LFS

This is priya.I tried LFS 6.1.1 November30th,2006 on host's Fedora-5 ,Fedora-4 ,and Suse-10 in X86 processor of 64 bit.every time i am getting problem at glibc-testing .But the main problem starts at installing binutils pass 1.
I hope that any of my host systems are not suporting the LFS version 6.1.1 .
any one can u suggest me in choosing suitable version of LFS for any of these 3 host systems.Or suggest me to overcome the problem
by using the same version .

Fedora -5 linux version-2.6.15 and gcc-4.1.0
Fedora-4 linux version 2.6.11 and gcc- 4.0.0
Suse-10 linux version-2.6.13 and gcc-4.0.2

thanks & regards

krishna priya

win32sux 05-29-2006 06:09 PM

have your tried the LFS live cd?? it should work almost perfectly...

as for a generic distro to use as a host for LFS 6.1.1, i can recommend slackware 10.2, as it's what i'm using and it's worked great so far...

jbennet1 06-09-2006 11:05 AM

Dontt use fedora 4 or 5 (dunno abou others) - the compiler wont do LFS, get the livecd or another distro

nykey 06-09-2006 04:05 PM

Try compiling it from a host with gcc version 3x not 4x , 4x is full of problems. For example I had LFS working using the LFS Live CD and Slackware 10.2 both with gcc 3x. And make sure to read the Errata too, and apply the patches from there every time you compile the packages are listed there... I got into alot of problems for not reading it :D. Good luck.

Lenard Spencer 06-29-2006 07:22 PM

I'm in the middle of installing LFS 6.1.1 right now, using Slackware 10.2, and there is something I'd like to add: make SURE you install the 2.6.13 kernel from disk 2, or at least make sure your kernel is at least 2.6.2 or newer, as it says in the book. I have to admit I just glossed over the earlier chapters before starting the install of the temporary tools, and under Slack's 2.4.31 kernel I was getting a rather high number of seg faults. After going back and installing 2.6.13, it took me a little over 2 hours to rebuild all the temp tools.

But yes, definitely, a near-vanilla distro like Slack or Gentoo are the way to go.

Youri 06-30-2006 01:56 PM

slackware for sure ^^ i did it twice with slack without probs at all (one with 2.4 kernel but that was at book 5.1 >< the other with 2.6.11) but now im trying it on an ubuntu host its like notin but probs >< (first few probs had to do with the fact i had a 64bit turion sooo those dont count but now i am trying clfs-error error error -.-)

carcassonne 07-03-2006 03:34 PM


Originally Posted by priya001
This is priya.I tried LFS 6.1.1 November30th,2006 on host's Fedora-5 ,Fedora-4 ,and Suse-10 in X86 processor of 64 bit.every time i am getting problem at glibc-testing.

Skip it. Skip the test. Especially if it has to do with some clock or timing resources in nptl.

Boot with the Live CD and use nALFS. Edit the glibc xml file (use vim from the live CD or scp the files to another machine to edit them) in both Chapter05 and Chapter06 to remove the make check (about three lines). Mount your install partition under /mnt/lfs (create the mount point before), format it, make it bootable, [EDIT: of course, format and make bootable, THEN mount it !! ;-)] copy your kernel config file to the skeleton directory under the name 'linux-kernel-config' and launch './runIt skeleton' from the nALFS directory on the CD.

Then let it cook between 3 to 5 hours. It takes 3 hours inside VmWare 5.5 on an AMD X86_64 dual core with 4 GB of RAM, and 5 hours on a 2.4 GHz Pentium 4 with 1 GB RAM.

Even though you may have Fedora, Slackware, SuSE, etc... You can still use the Live CD to compile and install LFS. I find it's a good way (not the ultimate !) to have a LFS system quickly.

When you've obtained your first LFS system, and then you start to add xorg and all that, then you can ponder how to make it a perfect build by doing all tests, and adding security, and all that. There's so much time that can be spend on only refining to your liking the build process, but first try to have a running system.

All times are GMT -5. The time now is 11:49 AM.