Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.


  Search this Thread
Old 03-06-2011, 12:18 PM   #1
LQ Newbie
Registered: Feb 2011
Distribution: arch linux
Posts: 17

Rep: Reputation: 0
Unhappy Setting up the boot process problem using GRUB on an LFS system!

Hello everyone!

Love to say i'm here because my LFS works .... but it doesn't

Ok, I'm using the book version 6.7 and i'm on chapter 8.4.

Im having problems with the last section of this page.

On issuing the following commands from the book:

grub> root (hd0,1)
grub> kernel /boot/grub/core.img
grub> boot
(except with a different hard drive identifier)
I get the following output from the terminal:

root:/# /sbin/reboot
WARNING: could not determine runlevel - doing soft reboot
  (it's better to use shutdown instead of reboot from the command line)
shutdown: /dev/initctl: No such file or directory
init: /dev/initctl: No such file or directory
root:/# grub> root (hd1,3)
bash: syntax error near unexpected token `('
root:/# grub> root(hd1,)
bash: syntax error near unexpected token `('
So something has gone wrong somewhere! But i'm not quite sure where. It seems as though grub isn't running for some reason. Any help appreciated!


EDIT: Could this be anything to do with broken symlinks at all?

Last edited by linuxpicaxe; 03-06-2011 at 01:04 PM.
Old 03-07-2011, 05:12 AM   #2
LQ Veteran
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2390Reputation: 2390Reputation: 2390Reputation: 2390Reputation: 2390Reputation: 2390Reputation: 2390Reputation: 2390Reputation: 2390Reputation: 2390Reputation: 2390

Do you have grub legacy on your host? If not, you cannot do step 8.4.3 (as stated in the book: so if you already have GRUB Legacy loaded you can load GRUB-1.98 through your old boot loader).

grub legacy and grub 1.98 are not the same!!

BTW: You can go 2 ways with grub:

1) Skip installing and configuring grub in LFS and use the boot-loader that starts your host (you do need to add an entry that points to LFS).
2) Install and configure grub that came with LFS (and possibly add an entry for your current host).

I personally use the grub that comes with LFS, this because (B)LFS is my main OS. If you only plan to play with LFS and want to keep your current host as main OS, I would use the boot-loader that came with your host.

Hope this helps.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuring grub to boot -Last step in LFS chaoswings Linux From Scratch 2 08-31-2008 02:19 PM
LFS 6.2 grub boot error 15 problem HedAche Linux From Scratch 1 08-02-2007 02:20 PM
Problem setting up a dual boot (WinXP/SUSE 10.0) system firecrotch Linux - General 3 02-05-2006 06:24 AM
Setting password on grub, wha to do after changing default values in /boot/grub/menu. sarajevo Linux - Security 1 08-17-2005 09:01 PM
Boot LFS with Grub darkmage Linux From Scratch 2 08-20-2002 01:53 PM > Forums > Linux Forums > Linux - Distributions > Linux From Scratch

All times are GMT -5. The time now is 04:12 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration