-   Linux From Scratch (
-   -   Re-starting LFS (

finegan 02-03-2002 05:25 PM

Re-starting LFS
Okay... I have no idea why I'm really posting this as I'm not actually having a problem... but here it goes:

LFS- 3.1
under Fileutils-4.1
My Mother Hen's machine is an AMD 1.2Ghz and running Slack 8, glibc 2.2.3.

There is a huge sed command here to avoid a seg fault problem with 'ls' specifically on AMD machines and glibc-2.2.3. I have that.

After I tried the sed twice, it wouldn't compile. I tried it without the sed, and the 'ls' in $LFS/bin works without seg faulting.

Am I doing something right or wrong? Does this seg fault problem happen every time, or only occasionally?



finegan 02-03-2002 09:43 PM

Halfway through Chapter 6 and no issues... I must have been paranoid.



P.S. something just occured to me that may be an issue in the long run, but won't bother me.

In chapter 5, where the kernel headers are installed, make dep, yadyadya... all of the defaults for multiple selections are accepted, blah blah blah, anyway, these days the default kernel is flagged as an i686. If someone were building LFS on a Pentium 1, wouldn't this lead to some problems down the line? Just wanted to know before bother the bossman, Lfslinux.

Mik 02-04-2002 02:18 AM

I might be wrong but all that's getting done there is creating a few header files which are then used to compile other things like glibc for example. As far as I know the i686 doesn't get put as a hard #define in the headers. So as long as you change it when you get around to really compiling the kernel then you should have no problem with it at all.

hanzerik 02-04-2002 05:58 AM

I had the same worries with fileutils, but didnt do the sed command either. ls worked correctlly so I guess were ok, I'm about half way through chapter6 and no major probs yet.

Maybe I missed it, but is it written anywhere that when you reinstall the same programs in chapter 6 as you do in 5 to start with fresh souce code? I ran into some probs when I tried to install the same programs again, but used fresh source and all was good.

hanzerik 02-04-2002 09:00 AM

I retract my post, got to the part in ch 6 where you install fileutils and am having probs. Went back an am redoing that part of ch 5 where you install fileutils, and am doing the fix for glibc.

All times are GMT -5. The time now is 03:07 AM.