-   Linux From Scratch (
-   -   pure 32 bit LFS Version SVN-20110110 trouble installing libX11 in BLFS (

mcamp73 01-17-2011 02:31 PM

pure 32 bit LFS Version SVN-20110110 trouble installing libX11 in BLFS
Alright, this is just the current version of the book I am following. I have tried 6.7, clfs multilib, LFS 64 bit and many others. At first I thought it was the way I was building the base system so I rebuilt it following different versions hence all the tries. I have search google in vain to find the answer with no luck. I have tried passing X11_CLFAGS and X11_LIBS in vain. As far as I can tell my environmental variables are set up properly in ld.conf but every time I get this far it ends up the same. Here is the fail code:

checking for pthread_self in -lc... yes
checking for poll... yes
checking keysymdef.h... /usr/X11R7/include/X11/keysymdef.h
checking if XLOCALEDIR support should be enabled... yes
checking for BIGFONT... yes
checking for stdlib.h... (cached) yes
checking for unistd.h... (cached) yes
checking for sys/param.h... yes
checking for getpagesize... yes
checking for working mmap... yes
checking for nl_langinfo... yes
checking for X11... configure: error: Package requirements (xproto >= 7.0.13 xextproto xtrans xcb >= 1.1.92 kbproto inputproto) were not met:

No package 'xtrans' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables X11_CFLAGS
and X11_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Please help I am going nuts on this. Somewhat of a Linux newbe here but I am learning and this project is helping in that respect.

mcamp73 01-17-2011 02:37 PM

Forgot to mention, my path is /usr/X11R7 and it is set up in bash profile as that as well

corbis_demon 01-19-2011 12:24 AM

I have had this issue and is solved by

export PKG_CONFIG_PATH=/usr/lib/pkgconfig
before compiling. The configure script expects to find the xtrans.pc file in your preferred PKG_CONFIG_PATH. (The above path, of course, maybe different in your case). Did you install the pkg-config program prior to this operation?

mcamp73 01-19-2011 04:30 PM

I did, I will try this later and report back if it worked, thanks for the tip.

mcamp73 01-22-2011 04:42 AM

It would seem that xtrans was being misplaced in /usr/X11R7/share/pkgconfig for some reason, moved it to X11R7/lib/pkgconfig and was able to configure finally.

All times are GMT -5. The time now is 11:35 PM.