-   Linux From Scratch (
-   -   Problem with Root and untaring/install permissions (

CragStar 11-23-2002 11:45 AM

Problem with Root and untaring/install permissions
This is has me confused :confused:

My problem is that when I go to untar a file, or run make install, as root (and only root) the file permissions change to a different number, and nothing is ever the same. This is a huge problem for me, as this shows here:

-rw------- 1 root root 4432926 Nov 23 17:18 gimp-data-extras-1.2.0.tar.bz2
-rw------- 1 root root 824407 Nov 23 17:13 xchat-1.8.10.tar.bz2

The two files are owned by root. When I untar them individually I get this at the xterm:

drwxrwxr-x 4 39902 100 496 Dec 25 2000 gimp-data-extras-1.2.0
drwxrwxr-x 9 500 500 920 Nov 23 17:38 xchat-1.8.10

As you can see, the new owners are 39902, 100 and 500!!! All I ran was this command:

tar xvjf filename.tar.bz2

Plus is the time right for the gimp-data-extras directory? Surely it should be the same day as Nov 23?!?

The thing is that this happens when I try to make install, fscking everything up, but only as root, the normal users accout are fine, which makes me a bit worried to be honest.

I think it is something simple, but I don't have a clue. Any help would be appreciated. Thanks.

fsbooks 11-24-2002 09:54 AM

An innocent explanation

My experience is that invoking tar as root preserves orginial owners. Simply, you do not have the UID or GUD found on the original system where the tar file was written (not that they had to have them either necessarily ;-) ...

Do yourself a test. Write a small tarfile as one user. Untar this as root. Untar this as another user on your system. Note the owners of the untarred files. Typically, root will preserve the original owners (as we would like it to), while files untarred by simple user will generally by default be owned by that user.

CragStar 11-24-2002 07:15 PM

Problem solved - I think
I think (in fact I know!) your right about permissions, they are preserved so I was barking up the wrong tree. Whoops. :)

Anyway, what had happened was that I untared some fluxbox styles and they ended up changing the permissions of the style directory, not allowing access for user accounts, so I thought that root was untaring wrong cus of some other problems I had had with my lfs distro. But they were all unrelated, just happened at the same time.

All times are GMT -5. The time now is 06:35 PM.