LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices


Reply
  Search this Thread
Old 05-08-2016, 11:13 PM   #1
Jigsaw
Member
 
Registered: Apr 2016
Location: Indonesia
Distribution: Debian
Posts: 77

Rep: Reputation: Disabled
No such file or directory at /usr/share/autoconf/Autom4te/FileUtils.pm line 326, <GEN3> line 5.


I can not install libdrm-2.4.66 in lfs 7.9.

Code:
sed -i "/pthread-stubs/d" configure.ac  && autoreconf -fiv                         && ./configure --prefix=/usr --enable-udev && make
autoreconf: Entering directory `.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force -I m4 ${ACLOCAL_FLAGS}
autoreconf: configure.ac: tracing
autoreconf: running: libtoolize --copy --force
libtoolize: putting auxiliary files in AC_CONFIG_AUX_DIR, 'build-aux'.
libtoolize: copying file 'build-aux/ltmain.sh'
libtoolize: putting macros in AC_CONFIG_MACRO_DIRS, 'm4'.
libtoolize: copying file 'm4/libtool.m4'
libtoolize: copying file 'm4/ltoptions.m4'
libtoolize: copying file 'm4/ltsugar.m4'
libtoolize: copying file 'm4/ltversion.m4'
libtoolize: copying file 'm4/lt~obsolete.m4'
autoreconf: running: /usr/bin/autoconf --force
autoreconf: running: /usr/bin/autoheader --force
Can't exec "/usr/bin/autoheader": No such file or directory at /usr/share/autoconf/Autom4te/FileUtils.pm line 326, <GEN3> line 5.
autoreconf: failed to run /usr/bin/autoheader: No such file or directory
root:/sources/xwindow/libdrm-2.4.66# ls /usr/share/autoconf/Autom4te/
C4che.pm  ChannelDefs.pm  Channels.pm  Configure_ac.pm	FileUtils.pm  General.pm  Getopt.pm  Request.pm  XFile.pm
 
Old 05-09-2016, 12:02 AM   #2
Tim Abracadabra
Member
 
Registered: May 2014
Location: USA, Wherever I may Roam
Distribution: debian 9.8 w/GNOME and KDE dual boot w/Win 10.| debian 7.11 w/Xfce, LFS 7.9, + Multi-boot w/Windows7
Posts: 122

Rep: Reputation: Disabled
Hi Jigsaw,

Quote:
autoreconf: failed to run /usr/bin/autoheader: No such file or directory
Does /usr/bin/autoheader exist in the chroot?
(or if past Chapter 6, in your LFS system/partition?)

It should have been installed back in in LFS 7.9 in 6.43. Autoconf-2.69.

Hope that helps,
Tim

Last edited by Tim Abracadabra; 05-09-2016 at 12:14 AM. Reason: Add - If past Chapter 6 ...
 
1 members found this post helpful.
Old 05-09-2016, 12:12 AM   #3
Jigsaw
Member
 
Registered: Apr 2016
Location: Indonesia
Distribution: Debian
Posts: 77

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Tim Abracadabra View Post
Hi Jigsaw,



Does /usr/bin/autoheader exist in the chroot?

It should have been installed in LFS 7.9 in 6.43. Autoconf-2.69.

Hope that helps,
Tim
I have autoheader in chroot.

Code:
root:/sources/xwindow# auto      
autoconf       autom4te       automake-1.15  autoreconf     autoupdate     
autoheader     automake       autopoint      autoscan
 
Old 05-09-2016, 12:34 AM   #4
Tim Abracadabra
Member
 
Registered: May 2014
Location: USA, Wherever I may Roam
Distribution: debian 9.8 w/GNOME and KDE dual boot w/Win 10.| debian 7.11 w/Xfce, LFS 7.9, + Multi-boot w/Windows7
Posts: 122

Rep: Reputation: Disabled
Your previous post was unclear to me, Please answer exactly.

Does autoheader exist in /usr/bin/ ?

Code:
ls -la /usr/bin/autoheader
Also is /usr/bin in your PATH ?

Code:
echo $PATH
Please include the whole command line that includes your command and all output.
Even if the output is just another command prompt.

Thanks,
Tim

Last edited by Tim Abracadabra; 05-09-2016 at 02:20 AM. Reason: Add commands for info, output posting format requested and why re-requested
 
Old 05-09-2016, 09:55 PM   #5
Jigsaw
Member
 
Registered: Apr 2016
Location: Indonesia
Distribution: Debian
Posts: 77

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Tim Abracadabra View Post
Your previous post was unclear to me, Please answer exactly.

Does autoheader exist in /usr/bin/ ?

Code:
ls -la /usr/bin/autoheader
Also is /usr/bin in your PATH ?

Code:
echo $PATH
Please include the whole command line that includes your command and all output.
Even if the output is just another command prompt.

Thanks,
Tim
Is there something wrong?

ls -la /usr/bin/autoheader
-rwxr-xr-x 1 root root 8540 May 4 20:36 /usr/bin/autoheader
root:/sources/xwindow/libdrm-2.4.66# echo $PATH
/usr/bin:/bin
 
Old 05-10-2016, 02:43 AM   #6
Tim Abracadabra
Member
 
Registered: May 2014
Location: USA, Wherever I may Roam
Distribution: debian 9.8 w/GNOME and KDE dual boot w/Win 10.| debian 7.11 w/Xfce, LFS 7.9, + Multi-boot w/Windows7
Posts: 122

Rep: Reputation: Disabled
Thanks for your reply with the output.

The reason I asked is that your original post says:

Quote:
Can't exec "/usr/bin/autoheader": No such file or directory at /usr/share/autoconf/Autom4te/FileUtils.pm line 326, <GEN3> line 5.
autoreconf: failed to run /usr/bin/autoheader: No such file or directory
Which seems to indicate that /usr/bin/autoheader could not be found when you
attempted to configure libdrm-2.4.66.

Your reply seems to indicate that in-fact /usr/bin/autoheader exists and
that directory is in your path.

One would think the configure could then find and use autoheader
but it did not. Quite puzzling.


One thing I did notice that in another thread you mention:

Quote:
I had an error at boot time message error "cannot find device eth0 interface etho doesn't exist"
But above you mention:

Quote:
I have autoheader in chroot.
This may be a language/communication issue but If:

You are booting into your live LFS system you created ..
Then adding packages like libdrm-2.4.66
Why would you be chrooting ??

On a live boot of LFS , I'd think that you (the system) should be using the
created virtual filesystems including /dev and root (/) is the LFS system,
Independent from the host system, so I see no reason for a chroot.
Someone please correct me if I am mistaken.

Are you chrooting in a live booted LFS system?

Otherwise, I am not sure why the libdrm-2.4.66 configure
can't find /usr/bin/autoheader.

Thats all I have, at least for now.
Likely someone else will chime in

Hope that helps,
Tim
 
Old 05-10-2016, 03:30 AM   #7
Jigsaw
Member
 
Registered: Apr 2016
Location: Indonesia
Distribution: Debian
Posts: 77

Original Poster
Rep: Reputation: Disabled
I am trying to remove and reconfigure try again but I can not, you try to look at my image http://s32.postimg.org/9ufwu6uac/Scr...0_15_18_01.jpg
 
Old 05-10-2016, 03:48 AM   #8
Tim Abracadabra
Member
 
Registered: May 2014
Location: USA, Wherever I may Roam
Distribution: debian 9.8 w/GNOME and KDE dual boot w/Win 10.| debian 7.11 w/Xfce, LFS 7.9, + Multi-boot w/Windows7
Posts: 122

Rep: Reputation: Disabled
Hmm,
My apologies if my questions which required answers was not clear:

Code:
Are you attempting what you are doing when booted in your host system OS
or are you booted into the LFS system you created?
Tim
 
Old 05-10-2016, 03:52 AM   #9
Jigsaw
Member
 
Registered: Apr 2016
Location: Indonesia
Distribution: Debian
Posts: 77

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Tim Abracadabra View Post
Hmm,
My apologies if my questions which required answers was not clear:

Code:
Are you attempting what you are doing when booted in your host system OS
or are you booted into the LFS system you created?
Tim
I install libdrm in my lfs not host os.
 
Old 05-10-2016, 04:19 AM   #10
Tim Abracadabra
Member
 
Registered: May 2014
Location: USA, Wherever I may Roam
Distribution: debian 9.8 w/GNOME and KDE dual boot w/Win 10.| debian 7.11 w/Xfce, LFS 7.9, + Multi-boot w/Windows7
Posts: 122

Rep: Reputation: Disabled
Yes, you say you are "installing" to LFS but:
Code:
What OS did you boot?
Also, insure that if you booted into your LFS system you do not mount any /proc, /dev, etc .. from the host
and do not chroot.


Also, it looks like from the screenshot you are attempting this task from, and with the source in the root directory.

Code:
Where is the source code located?
If in root (/), Not a good idea.

Maybe put it in /tmp and check the install instructions once you untar it to see if there are any other requirements.
(like its own build subdirectory ...

Also break down your processes and stop using && for this issue.
To troubleshoot it is typically helpful to do one thing at a time.
Once you successfully complete a step, only then move on to the next.

Your screenshot also provides additional info, Thanks!
It is not the configure or the make that is failing but
the autoreconf process.

I'd focus on that.

Last edited by Tim Abracadabra; 05-10-2016 at 04:23 AM. Reason: Fix code tag
 
Old 05-10-2016, 04:46 AM   #11
Jigsaw
Member
 
Registered: Apr 2016
Location: Indonesia
Distribution: Debian
Posts: 77

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Tim Abracadabra View Post
Yes, you say you are "installing" to LFS but:
Code:
What OS did you boot?
Also, insure that if you booted into your LFS system you do not mount any /proc, /dev, etc .. from the host
and do not chroot.


Also, it looks like from the screenshot you are attempting this task from, and with the source in the root directory.

Code:
Where is the source code located?
If in root (/), Not a good idea.

Maybe put it in /tmp and check the install instructions once you untar it to see if there are any other requirements.
(like its own build subdirectory ...

Also break down your processes and stop using && for this issue.
To troubleshoot it is typically helpful to do one thing at a time.
Once you successfully complete a step, only then move on to the next.

Your screenshot also provides additional info, Thanks!
It is not the configure or the make that is failing but
the autoreconf process.

I'd focus on that.
i'm using lfs boot sir, and I do not use chroot.
 
Old 05-10-2016, 05:04 AM   #12
Tim Abracadabra
Member
 
Registered: May 2014
Location: USA, Wherever I may Roam
Distribution: debian 9.8 w/GNOME and KDE dual boot w/Win 10.| debian 7.11 w/Xfce, LFS 7.9, + Multi-boot w/Windows7
Posts: 122

Rep: Reputation: Disabled
Quote:
Originally Posted by Jigsaw View Post
i'm using lfs boot sir, and I do not use chroot.
But previously you said:

Quote:
I have autoheader in chroot
.

Thanks for making that clear and that you are booting into your created LFS.

In troubleshooting, It is important to be exact.
My intent is to clarify the issue for not only myself but others who read
and may contribute to this thread.

All the best,
Tim
 
Old 05-10-2016, 05:35 AM   #13
Jigsaw
Member
 
Registered: Apr 2016
Location: Indonesia
Distribution: Debian
Posts: 77

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Tim Abracadabra View Post
But previously you said:

.

Thanks for making that clear and that you are booting into your created LFS.

In troubleshooting, It is important to be exact.
My intent is to clarify the issue for not only myself but others who read
and may contribute to this thread.

All the best,
Tim

perhaps because of this misunderstanding sorry if I did not explain in detail. before I wear chroot on the host, then I tried to wear a boot lfs but still error.
 
Old 05-10-2016, 06:09 AM   #14
spiky0011
Senior Member
 
Registered: Jan 2011
Location: PLANET-SPIKE
Distribution: /LFS/Debian
Posts: 2,426
Blog Entries: 1

Rep: Reputation: 387Reputation: 387Reputation: 387Reputation: 387
Hi is that echo $PATH root in lfs?
Quote:
root:/sources/xwindow/libdrm-2.4.66# echo $PATH
/usr/bin:/bin
Thats not correct
 
Old 05-10-2016, 06:27 AM   #15
Jigsaw
Member
 
Registered: Apr 2016
Location: Indonesia
Distribution: Debian
Posts: 77

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by spiky0011 View Post
Hi is that echo $PATH root in lfs?


Thats not correct
how true sir?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to share directory from command line? redss Ubuntu 3 10-04-2012 01:52 PM
can't locate object method "path" via package "Autom4te::Request" at/usr/bin/autom4te wjh513 Linux - Software 1 08-13-2010 02:31 PM
sh: line 1: /usr/bin/(swapd): No such file or directory QtCoder Linux - General 4 04-11-2005 05:33 PM
Error in man command "sh: line 1: /usr/bin/gtbl: No such file or directory" MinA Slackware 1 09-06-2004 06:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch

All times are GMT -5. The time now is 08:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration