LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices


Reply
  Search this Thread
Old 09-22-2005, 03:38 AM   #1
logicalfuzz
Member
 
Registered: Aug 2005
Distribution: Arch Linux
Posts: 291

Rep: Reputation: 48
MPlayer : GUI requires GTK devel packages ??


i have xorg 6.8.2, gtk2.8.3 installed on my LFS system.
while compiling Mplayer for gui, it said
Code:
Error: The GUI requires GTK devel packages (which were not found)
i tried to google 'gtk devel' and also tried sourceforge, but to no sucess.
pls guide as to where i can find gtk-devel SOURCE packages. (i've been coming across rpms)
 
Old 09-22-2005, 04:07 AM   #2
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 77
You have to install gtk 1.x.
 
Old 09-22-2005, 04:14 AM   #3
Harmaa Kettu
Member
 
Registered: Apr 2005
Location: Finland
Posts: 196

Rep: Reputation: 30
You can try this patch, which should make it work with gtk 2. Another option is disabling the GUI and using some alternative frontend instead.
 
Old 09-29-2005, 02:44 PM   #4
bluueknigh7
LQ Newbie
 
Registered: Sep 2005
Posts: 4

Rep: Reputation: 0
I'm getting the same error, though I'm on SuSE 9.3 and I KNOW that gtk1.2 and gtklib are installed. (I've even compiled gaim no problems)

How do you apply that patch (i'm a newb) - which file do I stick the text in?

And does anyone know why this error is happening?

Last edited by bluueknigh7; 09-29-2005 at 02:49 PM.
 
Old 09-29-2005, 09:17 PM   #5
logicalfuzz
Member
 
Registered: Aug 2005
Distribution: Arch Linux
Posts: 291

Original Poster
Rep: Reputation: 48
Code:
patch -Np1 -i <name-of-patch-file>
but the patch did not work for me on LFS. eventually i had to install gtk1.2 . see if it works on SUSE and make a post here. I face the same problem in RHEL (i have gtk1.2..but mplayer does not detect), but never bothered to fix it as i was quite comfortable with command line mplayer.
 
Old 09-30-2005, 05:47 AM   #6
abdula
LQ Newbie
 
Registered: Sep 2005
Posts: 1

Rep: Reputation: 0
to solve this problem try to get the gtkmm (a interface for the popular GUI libraries GTK+ and GNOME). I had th same problem here and that was solved by it.
 
Old 10-01-2005, 01:32 AM   #7
bluueknigh7
LQ Newbie
 
Registered: Sep 2005
Posts: 4

Rep: Reputation: 0
Quote:
Originally posted by abdula
to solve this problem try to get the gtkmm (a interface for the popular GUI libraries GTK+ and GNOME). I had th same problem here and that was solved by it.
This seemed easiest, so I tried it first and it works for me! Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gtk+ devel packages mindkill Linux - Software 1 09-12-2005 03:50 AM
how to add GTK devel packages? alexwang74 Linux - Software 4 06-14-2005 09:03 PM
MPlayer - GTK devel packages? Levitate Debian 14 12-30-2004 01:10 PM
libglade and gtk devel packages contrasutra Slackware 3 05-24-2003 05:25 PM
mplayer and gtk-devel and libpng-devel ... purpleburple Linux - Software 1 03-16-2003 03:57 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch

All times are GMT -5. The time now is 11:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration