-   Linux From Scratch (
-   -   Mpg123 not working - no audio output (

rogerfernandezg 12-17-2012 02:55 PM

Mpg123 not working - no audio output
Hi, I just installed Mpg123-1.14.4 in my LFS 7.2.

I run the command:

mpg123 Gerudo Valley.mp3

The output was:

High Performance MPEG 1.0/2.0/2.5 Audio Player for Layers 1, 2 and 3
version 1.14.4; written and copyright by Michael Hipp and others
free software (LGPL/GPL) without any warranty but with best wishes

Playing MPEG stream 1 of 1: Gerudo Valley.mp3 ...

MPEG 1.0 layer III, VBR, 44100 Hz joint-stereo
Title: Gerudo Valley Artist: Koji Kondo
Comment: PCCG-00475
Album: The Legend of Zelda Ocarina of Time Original Sound Track
Year: 1998 Genre: Game

There's no output sound. After that I booted into Ubuntu and chrooted to LFS 7.2, I run the same comands and it worked.

There's any package to output sound in LFS that I'm missing?

Thanks in advance.

spiky0011 12-17-2012 03:18 PM


Have you tried running it as root from lfs

And is the user a member of the audio group

Dont know if this helps

rogerfernandezg 12-17-2012 06:46 PM

Yep! I'm currently running as root and I've configured correctly the group file adding the proper privileges.

I tried to troubleshoot that with aplay tool, alsamixer and sound-test, no one worked. I think I'm lacking some drivers to detect my soundcard because in alsamixer I only have:

0 Dummy
2 pcsp
3 HDA Intel PCH

Just works the card0, others ones display errors.

I also recompiled the kernel and added some features to menuconfig, none worked.

Please help.

pikill 02-06-2013 10:35 AM

I am having the same problem. LFS 7.2, mpg123 works in chroot but not independently. The kernel is configured with my laptop Intel HD audio drivers. Have you found a solution?

Keith Hedger 02-08-2013 01:31 PM

Have you tried initing alsa? I had to do this:

alsactl init
alsactl store

as root before I had sound ( but I do use the proprietary nvidia driver )

pikill 02-08-2013 04:37 PM

Actually, I had only installed alsa-lib prior to mpg123. I noticed that alsa-lib did NOT put any default *.conf files anywhere so I:


cat > /etc/skel/.asoundrc <<"EOF"
# Begin .asoundrc
pcm.!default {
type hw
card 0

ctl.!default {
type hw         
card 0
# end

cp /etc/skel/.asoundrc /root/

Which may not have necessary. Then I continued on to build alsa-plugins & alsa-utils according to LFS 7.2 instructions and mpg123 just started working. Now I have sound on my LFS machine, its on to X11 ...

All times are GMT -5. The time now is 07:26 PM.