-   Linux From Scratch (
-   -   Make Loop (

notsoevil 02-10-2002 04:29 PM

Make Loop
I did a quick install of RedHat 7.1 to use as a base system for LFS compilation, installing the "development" packages and just those things I needed.

At installing bash in $LFS, the configure command and options runs fine (I decided to split it out from the '&&', and do each command individually). However, when I ran 'make', the configure script would run again (doing all the checking). I didn't think much of this, until I noticed the same screens ('check for blah blah blah') fly past over and over and over and ..

You get the point. So, I did 'make | more' to pause some of the screens, and before the whole thing loops again, the following message occurred:

make: *** Warning: File 'configure' has modification time in the future (2001-11-12 06:53:01 > 2000-06-15 12:13:45)

Note, this is after make was running for about 20 minutes or so. I hate wasting time like that.

Well, a quick run of 'date' tells me my system time is WAY off (set to the 'June 2000' date above. I update it, rerun make and everything is cool.

make and make install only took 1 minute or less.

So yeah, I fixed it, this isn't really a question. Just thought I'd put it out there for LFS 'notes' or whatever.


Mik 02-11-2002 03:51 AM

Weird that it would keep looping through and running it again. I guess it's because it only gave a warning and an error never really occurred. There are always simple little things you seem to run into when building an LFS, which often take lots of time to figure out.
I had a problem of my own which also had to do with the time. I was compiling gcc in chapter 6 and it kept complaining that I needed autoconf. Autoconf is a package that gets installed later in chapter 6 and if you don't modify the configure options then it should never need it. I scanned the mailinglist and there where several messages about making sure you didn't use the same source tree as in chapter 6. I hadn't done that but just to make sure I did the whole process again from a freshly unpacked source tree. Still the same error. I finally found a message about a guy rebooting his machine which magically solved the problem. I couldn't reboot right then because the machine was still busy with other things. But I figured that maybe because the ntpd was running it was changing the time in milliseconds which could somehow mess up with it checking to make sure a file wasn't modified. So I killed the ntpd and just to make sure I logged out and logged in again. After that it compiled without any complaints. I still don't know whether it was the ntpd or logging in and out which solved it. But I highly suspect that the ntpd was changing the time, especially since I was compiling on a 486 and quite a bit of time elapsed between starting the compile and getting the error.
Well at least I got past that, only several packages left to install in chapter 6. But they do take ages. I think I can take every time in the book and multiply it by 8 if not more, to figure out how long it takes to compile the package.

All times are GMT -5. The time now is 01:02 AM.