LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (https://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   Linux 4.4 seems to refuse to build IPv6 for the 64-bit build - 32-bit build works fine (https://www.linuxquestions.org/questions/linux-from-scratch-13/linux-4-4-seems-to-refuse-to-build-ipv6-for-the-64-bit-build-32-bit-build-works-fine-4175571649/)

GameCodingNinja 02-07-2016 10:48 AM

Linux 4.4 seems to refuse to build IPv6 for the 64-bit build - 32-bit build works fine
 
I decided to rebuild my Linux to the latest LFS & BLFS books. My process is automated and it's just a matter of updating my scripts and letting it build. Once I solved all the problems and have the 32-bit build running, it's just a matter of creating a new Linux config file for the 64-bit build and letting it run.

Generating the default config has everything I need except for my sound card. IPv6 network protocol is selected by default.I double check all the options I need but the sound is the only thing that needs to be set. I can look in the config file and see that IPv6 is enabled.

After I generate the 64-bit build, IPv6 does not appear to have been built. This is not the case with the 32-bit build. The networking part for the 32 and 64 bit config files are identical. Command line tests to query if IPv6 is enabled reports back negative when running the 64-bit build.

This is very odd. I've never encountered a problem like this before. I've also tried the latest stable Linux which is 4.4.1 with the same results.

GameCodingNinja 02-07-2016 11:37 AM

Never mind. After trying all sorts of tests, the one test I didn't do is try using a Linux config from my previous build. Typically, I like to start out fresh in the event new kernel features are part of the default config. That seems to be a problem with the 64-bit build. Something new might be gimping IPv6 for the 64-bit build.

GameCodingNinja 02-07-2016 06:40 PM

Even after a bunch of tests, I'm still not able to generate a Linux 4.# config file for 64-bit that will produce a working IPv6. My last build which was Linux 4.0.3 has a 64-bit config file that will work. I don't remember how I generated this config file because even if I load my last build that used Linux 4.0.3 and generate a new config file, building a 64 version of Linux 4.4 still doesn't produce a working IPv6.


All times are GMT -5. The time now is 01:11 PM.