-   Linux From Scratch (
-   -   LFS version 6.5 I'm on step 5.10 I have a problem with gcc-4.4.1 pass 2 (

redpill 01-29-2010 06:09 AM

LFS version 6.5 I'm on step 5.10 I have a problem with gcc-4.4.1 pass 2
I'm using LFS version 6.5 I'm on step 5.10 gcc-4.4.1 pass 2 my host system is Debian lenny 5 I'm beginer and I have tried to follow the steps of the book
but I do have a problem with the gcc, when I run the make command I got this


looking for a compliant stdint.h in stdint.h, checking for uintmax_t... yes
checking for uintptr_t... yes
checking for int_least32_t... yes
checking for int_fast32_t... yes
checking for uint64_t... yes
checking what to include in gstdint.h... stdint.h (already complete)
checking for an ANSI C-conforming const... (cached) yes
checking for off_t... (cached) yes
checking for int... (cached) yes
checking size of int... (cached) 4
checking for long... (cached) yes
checking size of long... (cached) 4
checking for ANSI C header files... (cached) yes
checking build system type... (cached) i686-pc-linux-gnu
checking host system type... (cached) i686-pc-linux-gnu
checking target system type... (cached) i686-pc-linux-gnu
checking for decimal floating point... bid
checking whether byte ordering is bigendian... (cached) no
configure: creating ./config.status
config.status: creating Makefile
config.status: creating config.h
config.status: config.h is unchanged
config.status: executing gstdint.h commands
make[2]: Entering directory `/mnt/lfs/sources/gcc-build/libdecnumber'
make[2]: Nothing to be done for `all'.
make[2]: Leaving directory `/mnt/lfs/sources/gcc-build/libdecnumber'
make[2]: Entering directory `/mnt/lfs/sources/gcc-build/gcc'
make[2]: Leaving directory `/mnt/lfs/sources/gcc-build/gcc'
make[1]: Leaving directory `/mnt/lfs/sources/gcc-build'

if somebody had the same out put but nothing special. so what can I do to solve this proble ?


ddaemonunics 01-29-2010 06:55 AM

where is the error ?

druuna 01-29-2010 09:23 AM


If this is the correct output, nothing is wrong.

I'm not sure why you think something is wrong, I can come up with 2 things:

1) checking whether byte ordering is bigendian... (cached) no
Nothing wrong here, it is just checking which endianness your machine uses.

2) Nothing to be done for `all'.
Certain parts don't have to be build (depending on what is [not] found during the configure step), these are skipped and make will tell you with the above mentioned message. Nothing to worry about.

Hope this clears things up a bit.

All times are GMT -5. The time now is 10:32 AM.