LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices


Reply
  Search this Thread
Old 07-02-2007, 04:42 AM   #1
hanzelko
LQ Newbie
 
Registered: Jul 2007
Location: Bratislava,Slovak Republic
Distribution: LFS
Posts: 3
Blog Entries: 1

Rep: Reputation: 0
LFS LiveCD + intel_agp (agpgart)


Hello.

I have computer with two graphic card. One is onboard intel + one extern ati. Both are enabled in BIOS (there is no possibility in BIOS to disable onboard graphic).

My problem is when I boot LFS LiveCD (or another disto like Ubuntu). The boot process load intel-agp + agpgart modules, which on my computer, crashes linux (kernel exception).

How can I disable loading on these modules by boot of LiveCD (because I can' boot any livecd).

I am sure that these modules makes problem, becuase I have instaled Madrive, than rebooted kernel with init=/bin/bash and removed in modules.preload loading of intel-agp and system boots and works perfectly. But with LFS LiveCD I can't boot.

Thanks for help
 
Old 07-02-2007, 04:02 PM   #2
mariogarcia
Member
 
Registered: Sep 2005
Distribution: debian, solaris 10
Posts: 202

Rep: Reputation: 31
disable the internal graphic card in bios.
the live cds load agpgart and intel-agp because the hardware is detected. if you disable the card on bios the card won't be detected by the live cd, therefore these modules won't be loaded as they are specific to Intel.
 
Old 07-03-2007, 03:38 AM   #3
hanzelko
LQ Newbie
 
Registered: Jul 2007
Location: Bratislava,Slovak Republic
Distribution: LFS
Posts: 3

Original Poster
Blog Entries: 1

Rep: Reputation: 0
No BIOS possibility.

Hello.

That's the problem, I have no possibility to disable it in BIOS. I have cheched the BIOS and not found it.

I will check it again.

So there is no possibity to disable loading of module by boot?
 
Old 07-03-2007, 11:07 AM   #4
mariogarcia
Member
 
Registered: Sep 2005
Distribution: debian, solaris 10
Posts: 202

Rep: Reputation: 31
the issue is with a live cd. just try to apply switches for the live cd to disable modules if they exist; or remaster your live cd and disable those modules. livecd being read only it loads the modules for the hardware it detects.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LFS livecd question-> sharptech Linux From Scratch 3 01-06-2007 09:38 AM
Having problems with LFS LiveCD threekgtvr4 Linux From Scratch 4 04-29-2006 01:56 AM
What I should do with LFS LiveCD files? golden_warrior Linux From Scratch 7 10-04-2005 03:57 PM
LFS LiveCD 6.1-2 satimis Linux From Scratch 6 07-25-2005 10:32 PM
agpgart and intel_agp toddmassey Linux - Laptop and Netbook 0 02-02-2005 04:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch

All times are GMT -5. The time now is 09:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration