-   Linux From Scratch (
-   -   LFS keyboard permanent configuration (

aloisius-a 06-04-2010 04:08 PM

LFS keyboard permanent configuration
Hi all,

I got a problem with LFS.
I completed the installation of LFS and all has gone right except the configuration of the keyboard.
My keyboard is an Italian one and there is no correspondence between the keys and what appears on the display and is entered in the system.
If I hit the command
loadkeys it euro2
the problem is overcome and there is correspondence between the key and what appears on the display but I have to hit this command after every restart.
How can I obtain a permanet configuration?
I suppose I have to introduce the command in an init script but I am not sure about which.

Please let me know how can I fix this issue.


ShadowCat8 06-04-2010 07:04 PM


Well, checking the current Stable LFS documentation, I found this here. From what I see there, it looks like what you need to do is set the keyboard layout in the console initscript.

console - Loads the correct keymap table for the desired keyboard layout; it also sets the screen font

Andrew Benton 06-06-2010 04:35 AM

If you want to make the keymap permanent, one option is to compile the keymap into your kernel. After you've run make menuconfig, just before you run make, run this command

loadkeys -m /usr/share/keymaps/i386/qwerty/ > drivers/char/defkeymap.c
There are 2 other maps you could try, and

All times are GMT -5. The time now is 10:14 PM.