-   Linux From Scratch (
-   -   LFS book 6.3 CH 5.14 Bash 3.2 "make error" (

croog 06-11-2008 09:40 PM

LFS book 6.3 CH 5.14 Bash 3.2 "make error"
When I try to run 'make' for bash-3.2 I get an error.

lfs:/mnt/lfs/sources/bash-3.2$ make
yacc -d ./parse.y
make: yacc: Command not found
make: *** [] Error 127
I have tried removing the bash-3.2 folder, re extract it, apply the patch, run configure, and still the same error.
If you have any ideas please let me know.:confused:

gerald_M2B 06-11-2008 10:12 PM

yacc is in the bison package. You may need to install it for use in your system.


croog 06-11-2008 10:31 PM

I already have bison 1.875 installed and when I go to '/usr/local/share/bison' yacc.c is there. But I still get the error.

gerald_M2B 06-12-2008 10:09 AM

The yacc executable needs to be in /usr/bin or /usr/local/bin OR a link to the executable needs to be in those locations or in your path. Your problem is that the executable is not located by make. Make the correction, and run, as root, ldconfig (if that is also needed.) Then try again.


croog 06-16-2008 04:20 PM

I looked and yacc was in '/usr/local/bin' and still no luck, so I created a link to '/usr/bin' and make ran without error. I guess it was only looking in '/usr/bin' on my system. Thanks for the help.:D


a-relieved-pup-here 08-14-2012 05:59 PM

20120814-1747 -
Yes, this fix, install bison on host, worked for me. Current LFS 7.1, on host, ubuntuStudio-64-10.04

Keith Hedger 08-15-2012 04:58 AM

Mark this thread as SOLVED

All times are GMT -5. The time now is 05:31 AM.