LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices


Reply
  Search this Thread
Old 04-23-2007, 06:32 PM   #1
ThePredator
LQ Newbie
 
Registered: Apr 2007
Posts: 3

Rep: Reputation: 0
LFS and Madwifi


I am trying to get LFS to work with my Atheros wireless card using the atheros drivers. I did the kernel options here madwifi.org/wiki/UserDocs/KernelConfig then built the madwifi (which made and installed correctly). Now when I boot into the LFS system I type "modprobe ath_pci", which returns to the next line signaling it runs properly, but then when I do "iwconfig" only lo comes up. Am I missing a step or are their more kernel options I need?
 
Old 04-23-2007, 08:11 PM   #2
osor
HCL Maintainer
 
Registered: Jan 2006
Distribution: (H)LFS, Gentoo
Posts: 2,450

Rep: Reputation: 78
You don’t use iwconfig and friends for madwifi drivers. You need wlanconfig and other madwifi tools that are in the madwifi-ng tarball.
 
Old 04-24-2007, 02:49 PM   #3
ThePredator
LQ Newbie
 
Registered: Apr 2007
Posts: 3

Original Poster
Rep: Reputation: 0
I did wlanconfig ath0 (after modprobe) and it said 'no such device'.
 
Old 04-24-2007, 03:34 PM   #4
osor
HCL Maintainer
 
Registered: Jan 2006
Distribution: (H)LFS, Gentoo
Posts: 2,450

Rep: Reputation: 78
Which version of the madwifi are you using? You might need to do “wlanconfig ath0 create wlandev wifi0 wlanmode sta” before you can begin to use ath0. Are there any messages in dmesg after loading the module?
 
Old 04-24-2007, 05:04 PM   #5
ThePredator
LQ Newbie
 
Registered: Apr 2007
Posts: 3

Original Poster
Rep: Reputation: 0
When I run dmesg it says "ath_hal: Module liscense "Proprietary" taints kernel". Then when I do the wlanconfig it says "wlanconfig: ioctl: No such device".

Last edited by ThePredator; 04-24-2007 at 05:05 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LFS 6.2: made mistake when going from lfs to root setup oldgeek Linux From Scratch 4 11-12-2006 09:00 PM
Madwifi-old + Aircrack/Trouble compiling madwifi Ashex Linux - Software 7 04-05-2006 11:39 PM
LFS Book Chapter 6 - 1st step (chroot to /mnt/lfs) doens't work bauld Linux From Scratch 11 03-15-2006 12:31 AM
Madwifi-old + Aircrack/Trouble compiling madwifi Ashex Linux - Software 0 03-05-2006 06:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch

All times are GMT -5. The time now is 09:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration