LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (https://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   LFS 9.1 - Error installing Binutils (https://www.linuxquestions.org/questions/linux-from-scratch-13/lfs-9-1-error-installing-binutils-4175675586/)

leighstern 05-20-2020 08:51 AM

LFS 9.1 - Error installing Binutils
 
Hi all. First Post. Working my way thru LFS9.1 and running into issues with section 5.4. I've posted the error codes below:

rm -rf $backupdir; exit $rc
/mnt/lfs/sources/binutils-2.34/missing: 81: makeinfo: not found
WARNING: 'makeinfo' is missing on your system.
You should only need it if you modified a '.texi' file, or
any other file indirectly affecting the aspect of the manual.
You might want to install the Texinfo package:
<http://www.gnu.org/software/texinfo/>
The spurious makeinfo call might also be the consequence of
using a buggy 'make' (AIX, DU, IRIX), in which case you might
want to install GNU make:
<http://www.gnu.org/software/make/>
make[3]: *** [Makefile:474: binutils.info] Error 127
make[3]: Leaving directory '/mnt/lfs/sources/binutils-2.34/build/binutils/doc'
make[2]: *** [Makefile:1134: info-recursive] Error 1
make[2]: Leaving directory '/mnt/lfs/sources/binutils-2.34/build/binutils'
make[1]: *** [Makefile:3632: all-binutils] Error 2
make[1]: Leaving directory '/mnt/lfs/sources/binutils-2.34/build'
make: *** [Makefile:853: all] Error 2


Not sure what the issue is here. I have downloaded the package a few times. I think I am working in the proper directory.

Much thanks.

business_kid 05-20-2020 01:29 PM

Well Welcome to LQ. It does say on your profile it's your 2nd podt, so I presume you answered someone.

Anyhow, Binutils is done first off the existing system, so you haven't really had toime to make a mistake:).
Code:

/mnt/lfs/sources/binutils-2.34/missing: 81: makeinfo: not found
WARNING: 'makeinfo' is missing on your system.
You should only need it if you modified a '.texi' file, or
any other file indirectly affecting the aspect of the manual.
You might want to install the Texinfo package:

It's fairly unequivocal. You need texinfo to build stuff. You need crazy stuff - awk, sed, glibc, texinfo, bison, flex, m4, etc to build things. They don't all use all of them every time, but you won't get far without them.

Install the package from your base system and try again.

leighstern 05-20-2020 02:35 PM

Much thanks for this. Im attempting to follow LFS instructions and binutils is the first install. As i am new to this, maybe i am missing something, but I think the intent is to follow the directions. I dont think (and i could be wrong, just ask my ex wife, she will tell you about me being wrong :) ) you are meant to use packages from other partitions.

Thanks

Keith Hedger 05-20-2020 07:18 PM

it depends on what os you are using as the host as to what you may need to install, please post the output of the version.sh script and also what you are using as a host, is it in vbox etc, also PLEASE use code tags.

hendrickxm 05-23-2020 12:54 PM

Did you run the version-check?
Any host distro information could help too. You will probably need to install some extra packages unless you are using slackware, LFS, gentoo, exherbo, ...


All times are GMT -5. The time now is 06:12 AM.