LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices


Reply
  Search this Thread
Old 03-30-2010, 05:55 PM   #1
smkh
LQ Newbie
 
Registered: Mar 2010
Posts: 15

Rep: Reputation: 2
LFS 6.6 boot problem


Hello,
I almost finished constructing LFS 6.6 but after rebooting it I got following error message:
cannot open root device "sda7" or unknown-block(2,0)
http://thumbsnap.com/vf/RMY8JA46.png

some information about my build:
->host computer : virtual machine running on vmware workstation with SCSI Hard drive (LSI Logic Adapter)
->host OS: kubuntu 9.10
->HDD partitions:
/dev/sda1 ext4 (kubuntu)
/dev/sda2 extended
/dev/sda5 ext4 (home partition)
/dev/sda6 swap
/dev/sda7 ext3 (LFS)

->LFS Linux kernel 2.6.32.7
-> /boot/grub/grub.cfg menu entry (on LFS partition):
{
insmod ext2
set root=(hd0,7)
linux /boot/vmlinux-2.6.32.7-lfs-6.6 root=/dev/sda7 ro
}

I think this problem related to SCSI Hard Drive but I don't exactly know which config flags should be set on kernel .config file for SCSI support, please help!

Last edited by smkh; 03-30-2010 at 05:59 PM.
 
Old 03-30-2010, 07:33 PM   #2
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
I've no idea what a vmware virtual machine is so I don't know if that is related to your problem but it looks to me like you need to work on your kernel config. Your Oops mentions RAID and NFS. Do you need to use them? If not, disable them in your kernel config. When you compile your new kernel, compile everything you think you'll need into the kernel. Don't use modules until you've got a working kernel. Find out what drivers you need. On your host system use lspci from pciutils. That should be your starting point. Compile support for everything it mentions into the kernel. Also on your host system use lsmod to see what modules it has loaded. make sure you compile all of them into the kernel. If you're not sure where to find how to enable those modules, read the help ? for each kernel option - it should say what the module it enables will be called. Read the kernel config from your host system - there should be a compressed copy at /proc/config.gz. Make sure you compile support for your root filesystem into the kernel.
 
1 members found this post helpful.
Old 03-31-2010, 12:21 AM   #3
crts
Senior Member
 
Registered: Jan 2010
Posts: 2,020

Rep: Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757
Quote:
set root=(hd0,7)
Shouldn't this be
Code:
set root=(hd0,6)
AFAIK, numbering of the harddisks begins at (hd0,0) for sda1. So sda7 would be (hd0,6).
I am also not sure about
Quote:
insmod ext2
since you have an ext3 partition on sda7. I know ext3 is basically an ext2 fs extended by journalling feature, but you might want to keep it this in mind.
 
Old 03-31-2010, 12:25 AM   #4
crts
Senior Member
 
Registered: Jan 2010
Posts: 2,020

Rep: Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757Reputation: 757
Quote:
I think this problem related to SCSI Hard Drive but I don't exactly know which config flags should be set on kernel .config file for SCSI support, please help!
If my above suggestion does not solve your problem, you might want to consider recompiling your kernel with an existing .config that works. I compiled my first kernel with the configuration of my Ubuntu distro and it gave me no problems.
 
Old 03-31-2010, 04:05 AM   #5
smkh
LQ Newbie
 
Registered: Mar 2010
Posts: 15

Original Poster
Rep: Reputation: 2
thank you from your help.
I used lspci command on host machine and found that it uses BusLogic Driver for SCSI storage controller so I enabled relevant flag on kernel config menu:
Device Drivers --> SCSI device support --> SCSI low-level drivers --> BusLogic SCSI support (CONFIG_SCSI_BUSLOGIC=y)
after making the kernel, instead of LFS grub, I used my kubuntu grub and add an entry for LFS:

title Gnu/Linux LFS 6.6
root (hd0,6)
kernel /boot/vmlinux-2.6.32.7-lfs-6.6 root=/dev/sda7 ro
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LFS can not boot slim.chen Linux From Scratch 1 07-24-2009 07:42 AM
LFS 6.2 grub boot error 15 problem HedAche Linux From Scratch 1 08-02-2007 02:20 PM
LFS Boot Problem(LILO,Two Distributions in Two Hard Disks) 51dunk Linux From Scratch 4 06-11-2007 09:57 AM
Before LFS boot ... tritong Linux From Scratch 2 01-11-2006 05:26 AM
lfs first boot slack-penguin Linux From Scratch 7 06-15-2002 08:22 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch

All times are GMT -5. The time now is 01:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration