-   Linux From Scratch (
-   -   LFS 4.1 book install hung at section 6.14: Glibc-2.3.1 (

SparceMatrix 05-25-2003 07:34 PM

LFS 4.1 book install hung at section 6.14: Glibc-2.3.1
Compiling my own o-system is an exciting project and I think everything has gone OK so far except this one section on installing Glibc-2.3.1. This is all in the latest Debian Woody and with LFS paperback and its CD.

I had some accidents, I forgot to install the glibc-linuxthreads the first time I tried to configure the Makefile. I went back and did that, but after running all the 'make' commands I started seeing departures from what the book told me to expect:

First when I ran


exec /static/bin/bash --login
I found that my "I have no name" prompt did not change as it said I should expect.

In the Configuring Glibc section 6.14.3, I am finding that the tzselect command is not recognized in the directory I am supposed to be in there in that part; which I assume to be /glibc-build. I found it in another directory there, /timezone, but when I run the command there it does not go. It gives an error to the effect:


/usr/share/zoneinfo/ ... not found
I tried going back and running the localedef command, but despite finding the actual command in another directory and running it there, I get a 'no such file or directory' error. It's as if it doesn't exist.

What is going on? Should I ignore these errors? This is mostly a test install. Did I forget something?

Any and all tips and clues would be appreciated.

lfslinux 05-25-2003 08:58 PM

it doesn't matter what directory you are in when you run tzselect because it' gets installed in /usr/bin.

But, if tzselect is missing, and /usr/share/zoneinfo/ is missing too, it most likely means (a 99.99% chance) that when you ran this command:

echo "cross-compiling = no" > configparms

you didn't run it, or you made a typo. This is supposed to be run immediately after the configure script is done.

If you don't run that command, timezone files will be installed and the tzselect program won't work either and there might be many other Glibc related problems.

So, remove glibc-build and try again.

SparceMatrix 05-26-2003 01:31 AM

No, there was no typo, and I am pretty sure that I ran that part in the right order. The command again is:

echo "cross-compiling = no" > configparms

And it is run in the glibc-build directory.

I tried 'rm -r ./glibc-build' as suggested and starting again from the bottom of page 88 with the 'mkdir' command. But, I am still having the same problem. Running the exec command makes no change and tzselect is not found. /usr/share/zoneinfo is there, but it is empty. I am the running the config and make commands as directed from the glibc-build directory.

Could this problem be derived from a permissions issue? I am running from root after chrooting, so I don't see how that could be it. Could it be some setting in my Debian Woody installation?

Any and all tips and clues would be appreciated.

Here's something ...

I have my source files in something other than /usr/src. There was nothing in the book saying where these files should be stored. I tried, vainly, to mount a drive with the source files to /mnt/src so I just copied them there. Could that be it? If this is it, placing the source files in that location might be a good hint because I did worry about where they went.

lfslinux 05-26-2003 10:27 AM

It doesn't matter one bit where the source files are stored, nor where you unpack and build. As long as the configure paramaters are identical to the ones in the book all will be ok.

If your timezone files were not installed, it simply means that Glibc thought you have a cross-compiler. Indeed, if you look at Glibc's configure output it will tell you it detected a cross-compiler because Glibc wasn't installed yet (the GCC cross-compile test needs Glibc installed, so the test fails and configure assumes you then have a cross-compiler). Since this is the wrong thing to do, that configparms file is created to override that settings.

But, you said you already did all that, I can't think of anything else by this medium, I need to have a look at your glibc-build directory.

Please remove glibc-build and glibc-2.3.1 again, unpack the archives (don't forget linuxthreads) and configure it again. Run every command but not "make" and futher on (that means the echo cross-compiling=no is the last command you should run).

After that, create a .tar.bz2 file of the glibc-build directory and email it to me at

I'll check to make sure that all files have the proper contents.

SparceMatrix 05-30-2003 04:56 PM

Problem solved.

The problem was that I did not unpack both packages for GCC in the first part of the installation. There is the "core" package and the "gcc" package and I was just unpacking the core package. Everything is functioning as it should in the Glibc part of the basic software part of the installation.

All times are GMT -5. The time now is 08:30 PM.