LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices


Reply
  Search this Thread
Old 08-02-2009, 01:12 PM   #1
Seph64
Member
 
Registered: Feb 2003
Distribution: Gentoo, FreeBSD, LFS
Posts: 298
Blog Entries: 21

Rep: Reputation: 30
Kernel spitting out messages during the init process.


Although I figure it must be due with the kernel config I am using, but during the init process (after the kernel loads), the kernel spits out a big load of messages that mixes with the init messages.

This would not be a problem if I knew everything was initialising ok. But there's a bootscript that is fails to load/work, and I can not tell what it is or why it is failing because of all the kernel messages.

I tried passing quiet through the boot options, but that only keeps the kernel quiet until the init process begins.

I am going to try using the .config the lfs livecd uses and recompile the kernel with that to see if that fixes the problem.

EDIT: Outputs from various commands + the kernel config I used (that booted successfully) have been posted on my blog: http://www.linuxquestions.org/blog/s...25#comment2725

I should've posted them in here in the first place, but that's why I edited this post. I hope I can get some help on making a working config soon.

Last edited by Seph64; 08-02-2009 at 04:26 PM.
 
Old 08-02-2009, 06:02 PM   #2
hoes
Member
 
Registered: Sep 2005
Distribution: debian, linux from scratch
Posts: 190

Rep: Reputation: 51
I don't see the actual lines you see when booting.
Could you post them somewhere?
Check the logfiles for them, especially kernel.log.
And there is also a command to read kernel logs, but Ican't quite reminder how it's called.
 
Old 08-02-2009, 06:36 PM   #3
Seph64
Member
 
Registered: Feb 2003
Distribution: Gentoo, FreeBSD, LFS
Posts: 298

Original Poster
Blog Entries: 21

Rep: Reputation: 30
http://pastebin.com/m2a44de58

That's from the first working kernel.

I just do not understand why the kernel is just spamming these messages during the init process.

I am going to compile a different kernel version to see if the problem is localized in the version of the kernel I am using.

Last edited by Seph64; 08-02-2009 at 07:03 PM.
 
Old 08-03-2009, 04:35 AM   #4
markor
LQ Newbie
 
Registered: May 2008
Posts: 10

Rep: Reputation: 0
Post

It is also a bit of hassle here, I have been using Ubuntu kernel in distribution and after some of kernel updates, it is spitting those messages during boot, with no reason.
(I used to use usb adsl modem).
But after another (small, same version and revision) kernel update,
problem was not there anymore.
It happened again after several automatic upgrades and fixed itself againg with kernel upgrade with same version.

So It seem to me it is like misconfigured something in build options Or some patches where not done right, few times.
 
Old 08-03-2009, 04:40 AM   #5
hoes
Member
 
Registered: Sep 2005
Distribution: debian, linux from scratch
Posts: 190

Rep: Reputation: 51
I don't know what all this hassle is about.
You only get a lot of messages and the aren't even errors.
If you want to decrease the amount of messages, you should configure klogd.
That is the logger for kernel messages.

Have a look at:
http://www.linuxjournal.com/article/4058
 
Old 08-03-2009, 07:43 AM   #6
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,083

Rep: Reputation: 405Reputation: 405Reputation: 405Reputation: 405Reputation: 405
I fail to see the problem either. That's what the kernel does, spit out messages. Nothing wrong with that.

Quote:
Originally Posted by Seph64 View Post
http://pastebin.com/m2a44de58

That's from the first working kernel.

I just do not understand why the kernel is just spamming these messages during the init process.
Respectfully, nope

The thing you pasted in that link happens *before* init goes into scene. That's the kernel booting, init comes *after* that.

If you are bothered by these messages I think that you can remove them by correctly configuring the kernel boot line in your grub/lilo.conf by adding the "quiet" option. The framebuffer configuration might have something to do with this as well, I don't know cause I really don't feel any sympathy for all this candy which is designed to hide everything which is happening behind the scenes and confuse me in the way. However, I understand why some people might find that info useless. Still, it's just info, not errors.

Quote:
Originally Posted by hoes View Post
I don't know what all this hassle is about.
You only get a lot of messages and the aren't even errors.
If you want to decrease the amount of messages, you should configure klogd.
That is the logger for kernel messages.

Have a look at:
http://www.linuxjournal.com/article/4058
The system logger is started during init, so, it will have absolutely no effect at all over anything that happens before init, which is the case.
 
Old 08-03-2009, 09:59 AM   #7
Seph64
Member
 
Registered: Feb 2003
Distribution: Gentoo, FreeBSD, LFS
Posts: 298

Original Poster
Blog Entries: 21

Rep: Reputation: 30
Quote:
Originally Posted by i92guboj View Post
I fail to see the problem either. That's what the kernel does, spit out messages. Nothing wrong with that.



Respectfully, nope

The thing you pasted in that link happens *before* init goes into scene. That's the kernel booting, init comes *after* that.
Read Below.

Last edited by Seph64; 08-03-2009 at 10:07 AM.
 
Old 08-03-2009, 10:01 AM   #8
hoes
Member
 
Registered: Sep 2005
Distribution: debian, linux from scratch
Posts: 190

Rep: Reputation: 51
Quote:
There's no log that includes the init log and these messages together, but yes, the bottom portion of these messages ARE appearing during init.
Can you indicate what is posted during init and what not?
 
Old 08-03-2009, 10:03 AM   #9
Seph64
Member
 
Registered: Feb 2003
Distribution: Gentoo, FreeBSD, LFS
Posts: 298

Original Poster
Blog Entries: 21

Rep: Reputation: 30
What? I have photographic memory?

Hmm, actually, maybe this is the wrong log file after all. Lemme check the logs again.

Code:
Aug  2 04:58:48 Sephnix kernel: usb-storage: device scan complete
Aug  2 04:58:48 Sephnix kernel: isa bounce pool size: 16 pages
Aug  2 04:58:48 Sephnix kernel: usb-storage: device scan complete
Aug  2 04:58:48 Sephnix kernel: scsi 6:0:0:0: Direct-Access     Dell     USB Mass Storage  200 PQ: 0 ANSI: 0
Aug  2 04:58:48 Sephnix kernel: scsi 7:0:0:0: Direct-Access     Apple    iPod             1.62 PQ: 0 ANSI: 0
Aug  2 04:58:48 Sephnix kernel: sd 6:0:0:0: [sdb] Attached SCSI removable disk
Aug  2 04:58:48 Sephnix kernel: sd 6:0:0:0: Attached scsi generic sg2 type 0
Aug  2 04:58:48 Sephnix kernel: sd 7:0:0:0: [sdc] 19488471 4096-byte hardware sectors: (79.8 GB/74.3 GiB)
Aug  2 04:58:48 Sephnix kernel: sd 7:0:0:0: [sdc] Write Protect is off
Aug  2 04:58:48 Sephnix kernel: sd 7:0:0:0: [sdc] Mode Sense: 68 00 00 08
Aug  2 04:58:48 Sephnix kernel: sd 7:0:0:0: [sdc] Assuming drive cache: write through
Aug  2 04:58:48 Sephnix kernel: sd 7:0:0:0: [sdc] 19488471 4096-byte hardware sectors: (79.8 GB/74.3 GiB)
Aug  2 04:58:48 Sephnix kernel: sd 7:0:0:0: [sdc] Write Protect is off
Aug  2 04:58:48 Sephnix kernel: sd 7:0:0:0: [sdc] Mode Sense: 68 00 00 08
Aug  2 04:58:48 Sephnix kernel: sd 7:0:0:0: [sdc] Assuming drive cache: write through
Aug  2 04:58:48 Sephnix kernel:  sdc: sdc1
Aug  2 04:58:48 Sephnix kernel: sd 7:0:0:0: [sdc] Attached SCSI removable disk
Aug  2 04:58:48 Sephnix kernel: sd 7:0:0:0: Attached scsi generic sg3 type 0
Aug  2 04:58:49 Sephnix kernel: usb-storage: device scan complete
Aug  2 04:58:49 Sephnix kernel: scsi 8:0:0:0: Direct-Access     WD       10EACS External  1.75 PQ: 0 ANSI: 4
Aug  2 04:58:49 Sephnix kernel: sd 8:0:0:0: [sdd] 1953525168 512-byte hardware sectors: (1.00 TB/931 GiB)
Aug  2 04:58:49 Sephnix kernel: sd 8:0:0:0: [sdd] Write Protect is off
Aug  2 04:58:49 Sephnix kernel: sd 8:0:0:0: [sdd] Mode Sense: 23 00 00 00
Aug  2 04:58:49 Sephnix kernel: sd 8:0:0:0: [sdd] Assuming drive cache: write through
Aug  2 04:58:49 Sephnix kernel: sd 8:0:0:0: [sdd] 1953525168 512-byte hardware sectors: (1.00 TB/931 GiB)
Aug  2 04:58:49 Sephnix kernel: sd 8:0:0:0: [sdd] Write Protect is off
Aug  2 04:58:49 Sephnix kernel: sd 8:0:0:0: [sdd] Mode Sense: 23 00 00 00
Aug  2 04:58:49 Sephnix kernel: sd 8:0:0:0: [sdd] Assuming drive cache: write through
I believe this is the stuff that gets spit out during init. I believe it has something to do with external storage devices (External Hard Drive, and iPod).

Last edited by Seph64; 08-03-2009 at 10:06 AM.
 
Old 08-03-2009, 10:05 AM   #10
hoes
Member
 
Registered: Sep 2005
Distribution: debian, linux from scratch
Posts: 190

Rep: Reputation: 51
I'd don't presume you have that but you could take a note of the first line you see flashing by during the init and copy from that line onwards from your log files. Just an idea.
But if you can indicate where it gets mixed that would help to pinpoint what is happening
 
Old 08-03-2009, 10:10 AM   #11
Seph64
Member
 
Registered: Feb 2003
Distribution: Gentoo, FreeBSD, LFS
Posts: 298

Original Poster
Blog Entries: 21

Rep: Reputation: 30
What I am going to do is disconnect my external storage devices and see if it still spits out these messages.

Alright, I narrowed it down:

Code:
Aug  3 02:12:45 Sephnix kernel: [   22.850117] ACPI: PCI Interrupt 0000:03:02.0[A] -> GSI 18 (level, low) -> IRQ 18
Aug  3 02:12:45 Sephnix kernel: [   22.850276] Model 1003 Rev 00000000 Serial 10031102
Aug  3 02:12:45 Sephnix kernel: [   22.950333] Adding 1951856k swap on /dev/sda7.  Priority:1 extents:1 across:1951856k
Aug  3 02:12:45 Sephnix kernel: [   23.695221] EXT3 FS on sda5, internal journal
Aug  3 02:12:45 Sephnix kernel: [   23.759285] kjournald starting.  Commit interval 5 seconds
Aug  3 02:12:45 Sephnix kernel: [   23.759505] EXT3 FS on sda6, internal journal
Aug  3 02:12:45 Sephnix kernel: [   23.759617] EXT3-fs: mounted filesystem with ordered data mode.
Aug  3 02:12:45 Sephnix kernel: [   24.424806] e1000: eth0: e1000_watchdog: NIC Link is Up 100 Mbps Full Duplex, Flow Control: RX/TX
Aug  3 02:12:45 Sephnix kernel: [   24.424921] e1000: eth0: e1000_watchdog: 10/100 speed: disabling TSO
Aug  3 02:12:55 Sephnix kernel: [   34.426189] eth0: no IPv6 routers present
After disconnecting the external storage devices, this is what is left that gets spit out during the init process.

Last edited by Seph64; 08-03-2009 at 10:17 AM.
 
Old 08-03-2009, 10:34 AM   #12
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 55
These messages are perfectly normal - as hoes and i92guboj said.
Every piece of hardware in your machine which the kernel has built in support for will be recognized and configured - before init.
These messages are shown - unless you have a boot-time splash screen hiding them from you.

It is less messages now because there are less devices now.

You may be used to a "quiet" bootsplash which often is the default - and now are seeing what is normally shown, but what you did not yet see until your bootsplash somehow disappeared or is configured to not be quiet?

HTH
 
Old 08-03-2009, 10:38 AM   #13
Seph64
Member
 
Registered: Feb 2003
Distribution: Gentoo, FreeBSD, LFS
Posts: 298

Original Poster
Blog Entries: 21

Rep: Reputation: 30
Yes, lets assume I am using a bootsplash on a brand new LFS installation...

I do not use a bootsplash, and the messages I specified are found during init.

I'll say this in big bold letters,STOP MAKING ASSUMPTIONS!
 
Old 08-03-2009, 10:48 AM   #14
hoes
Member
 
Registered: Sep 2005
Distribution: debian, linux from scratch
Posts: 190

Rep: Reputation: 51
Please, seph64, take some time to read over the posts.
Everyone is saying it is normal you see those messages.
I see similar messages every time I boot.

I could be that this is the first time you see them, because they are normally filtered.
I suggested it could have something to do with klogd and it was also suggested it is because you normally have a bootsplash.

The idea about a bootsplash is that you normally have one configured which makes sure messages are hidden. On a new LFS system no bootsplash is configured and so you see the messages. Hope that makes sense to you.

Please, consider that all these people responding are only trying to help. They are not telling you what the problem is, but what might cause the problem. It is up to you to investigate these cases. Just remember that all these people are only trying to help with their personal experience. If you don't agree with what they are saying, than you can say so and start a discussion about it or ask for a way that you could check whether an assumption is the case or not. People are willing to help.
 
Old 08-03-2009, 10:53 AM   #15
Seph64
Member
 
Registered: Feb 2003
Distribution: Gentoo, FreeBSD, LFS
Posts: 298

Original Poster
Blog Entries: 21

Rep: Reputation: 30
Well yes, I am sorry, but I have never seen these messages before, even in previous installed LFS systems when they were freshly installed.

So it's kinda irritating to see these "normal" messages now when they never appeared in previous fresh installs of LFS.

I am sorry.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel panic - not syncing: No init found. Try passing init= option to kernel ranjithmrk Linux - Newbie 4 08-22-2008 03:33 PM
Samba smbd constantly spitting error messages to syslog Noffie Linux - Networking 3 04-18-2008 07:51 PM
JFFS2 [VFS mount root /dev/mtdblock2 ok] - kernel panic on running init process sud_vijay Linux - Kernel 0 03-05-2008 11:05 AM
Compiled own kernel and got: Kernel panic: No init found. Try passing init= option to fbl Linux - General 12 01-14-2003 04:38 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch

All times are GMT -5. The time now is 01:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration