-   Linux From Scratch (
-   -   Kernel Panic during first boot (

MasterC 06-06-2002 04:57 AM

Kernel Panic during first boot
I can't boot into my new LFS system yet. I get into the boot sequence, and about the time where my Mandrake system would say:
Init version 2.8

Welcome to Mandrake Linux
Press "I" for interactive startup

Instead my LFS system freezes and says:

Kernel panic! Try passing init= to the kernel

Or something very close to that. I was thinking it was my iniitab file, but I copied the one from my bootable system to the $LFS/etc directory, but still, same error. So I copied from the bootable /boot directory the init.img file to my $LFS/boot, but still no luck.

Any suggestions?

slack-penguin 06-08-2002 08:10 PM

did you compile the kernel ;)

This sorta thing normally means either you didn't update lilo properly, or it can't find the kernel. I've had it so many times and it normally means somthing like that.

Apart from that, I can't think of anything else. There are lost of threads around on kernel panics tho if you do a search :)

MasterC 06-08-2002 11:18 PM

Yeah, I did the search first, and tried them all. No luck yet. Yeah, I thought of the kernel thing too, (and yes at first I did compile it) so I recompiled it just to make sure, but same thing still. I am going to check on that lilo thing, I think that may be where my problem is. Thanks for the ideas!

tunedLow 06-09-2002 03:25 AM

In lilo make sure root= points to / and not /boot. I had the same error and when I switched that if booted.

lfslinux 06-09-2002 11:47 AM

Also make sure you selected the proper partition to be mounted as the root partition. If LFS sits on /dev/hdb1 but you selected /dev/hdb2 (which may be the /home partition) then the kernel will mount /dev/hdb2 as / and try to run /sbin/init which doesn't exist so it'll panic. This is one reason. Just make sure that all paths and devices are properly setup in the lilo configuration file and apply to the way LFS is setup. Not the way the host distribution is setup (in case you copied the host distro's lilo.conf file)

MasterC 06-10-2002 09:35 AM

Cool, but now I am slightly confused? In the lilo.conf under $LFS/etc/lilo.conf do I just add entries for my LFS system so it should look something like this:


Rather than looking like this:

append="blah blah"


blah blah...

And so on. Should it be the very simple lilo, as shown above, and not a mirror of the lilo shown in the host systems /etc/lilo.conf ?

Thanks for any info

slack-penguin 06-12-2002 02:06 AM

you can keep the mandrake stuff in there is you're gonna keep it. Just make sure root points to the lfs partition and boot points to the lfs kernel and you should be right...

All times are GMT -5. The time now is 05:07 PM.