LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux From Scratch (https://www.linuxquestions.org/questions/linux-from-scratch-13/)
-   -   Issues when running "make" for libstdc++. (https://www.linuxquestions.org/questions/linux-from-scratch-13/issues-when-running-make-for-libstdc-4175653924/)

JustSomeAwesomeGuy 05-15-2019 02:52 AM

Issues when running "make" for libstdc++.
 
Hello all! So this is my first time using LinuxFromScratch and so far I am actually having a lot of fun and I have learn't a lot! So I have been following tutorials as well as the official LFS instructions but I am stuck on "Chapter 5. Constructing a Temporary System".

Everytime I run "make" it fails and I am not really sure why. I have done the required steps but maybe I did something wrong? I am not sure... Anyway, if anyone with some experience could maybe help me out, I would really appreciate it!

My config.log:
https://pastebin.com/JyxYGxn8


Thanks and good day! :)

Keith Hedger 05-15-2019 08:38 AM

post the output of the version check script, don't stray from the LFS book!

drillsar 05-15-2019 01:00 PM

It looks like your missing some basic software needed..


go to the following and run the script.

http://linuxfromscratch.org/lfs/view.../hostreqs.html

drillsar 05-15-2019 01:04 PM

One issue to be sure to check is that bash is linked to /bin/sh. When I built LFS first time I was going crazy finding out why it wasn't building and further investigation was that the host bash didn't link to /bin/sh

JustSomeAwesomeGuy 05-15-2019 11:52 PM

Hey guys! I listened to some of your potential solutions but it unfortunately did not work.

My bash version test:
https://pastebin.com/WqYMixvG

Current config.log (updated since the last make attempt):
https://pastebin.com/w329vdsd

drillsar 05-17-2019 06:25 AM

Your bash is located /bin/bash for LFS it is supposed to be /bin/sh. not sure if that is your problem.

JustSomeAwesomeGuy 05-17-2019 10:55 PM

So.. I have reset everything and restarted, doing everything by the book and I am still having the same issue!

Keith Hedger 05-18-2019 07:11 AM

Quote:

Originally Posted by drillsar (Post 5996037)
Your bash is located /bin/bash for LFS it is supposed to be /bin/sh. not sure if that is your problem.

I think u have this about face, bash should be at '/bin/bash' '/bin/sh' should be a symlink to '/bin/bash'

drillsar 05-18-2019 12:07 PM

Yes Keith you're correct

drillsar 05-18-2019 03:07 PM

Wich LFS Book you using?

drillsar 05-18-2019 08:15 PM

Do you have texinfo installed? Not sure that be the reason for error but looks like texinfo is not installed on your host. On Ubuntu you have to go to software and check the boxes. Then sudo apt-get install texinfo..

JustSomeAwesomeGuy 05-20-2019 12:22 AM

Quote:

Originally Posted by drillsar (Post 5996607)
Wich LFS Book you using?

As in I am following everything from the stable guide at http://www.linuxfromscratch.org/lfs/view/stable


All times are GMT -5. The time now is 09:56 PM.