-   Linux From Scratch (
-   -   Interface eth0 doesn't exist. LFS 6.5 on VirtualBox (

guodah 11-16-2010 07:24 AM

Interface eth0 doesn't exist. LFS 6.5 on VirtualBox
I have built LFS 6.5 on VirtualBox.

The system can boot while getting an warning: "Interface eth0 doesn't exist.". After reading some posts on these forums, I suspect that I did not select the correct network device driver. But do not know what to do next.

Any idea?

Thanks a lot!

catkin 11-16-2010 07:34 AM

You need a kernel module (built in or loaded) to match the virtual hardware. The default "PCnet-FAST III" requires the pcnet32 module.

guodah 11-17-2010 08:54 PM

catkin, Thanks!

How could I install the pcnet32 module? I did some search online. It seems pcnet32 is a VMWare tool/driver.

I tried "modprobe pcnet32" and it shows


WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/.
FATAL: Module pcnet32 not found.

Any suggestions are greatly appreciated!

catkin 11-17-2010 09:10 PM

pcnet32 is the module name in Slackware64 which is Linux-standard in most respects so that will probably be the name in LFS too. That being the case you could build the pcnet32 module. Alternatively you could change the virtual NIC's hardware to one that is already supported by your kernel modules if any.

guodah 11-18-2010 09:23 PM

catkin: thanks for your pointer!

I followed the instruction at and eth0 interface can be found now!

catkin 11-18-2010 09:39 PM

Glad you solved it. The thread can be marked SOLVED using the Thread Tools menu.

All times are GMT -5. The time now is 01:34 AM.