LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices


Reply
  Search this Thread
Old 06-21-2007, 02:42 PM   #1
aleksanteri
LQ Newbie
 
Registered: Jun 2007
Location: Finland
Distribution: Debian Lenny (Testing)
Posts: 14

Rep: Reputation: 0
"Interface eth0 doesn't exist. [ WARN ]" on boot-up


I'm trying to get my internet working for my LFS system I just today managed to make it work.

What happens is that I get
Code:
Bringing up the eth0 interface...
    Interface eth0 doesn't exist.    [ WARN ]
on bootup.

Code:
root:/# grep -H . /sys/class/net/*/address
grep: /sys/class/net/*/address: No such file or directory


Code:
root:/# cat /etc/udev/rules.d/26-network.rules
ACTION=="add", SUBSYSTEM=="net", SYSFS{address}=="00:00:00:00:00:00", NAME=="eth0"
Code:
root:/# cat /etc/sysconfig/network-devices/ifconfig.eth0/ipv4
ONBOOT=yes
SERVICE=ipv4-static
IP=192.168.0.101
GATEWAY=192.168.0.254
PREFIX=28
BROADCAST=192.168.1.255
Code:
aleksanteri@K4:~$ lspci
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
00:04.0 Multimedia audio controller: nVidia Corporation CK804 AC'97 Audio Controller (rev a2)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev f2)
00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev a3)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
05:00.0 VGA compatible controller: nVidia Corporation Unknown device 0162 (rev a1)
Any help would be appreciated

Last edited by aleksanteri; 06-21-2007 at 02:51 PM.
 
Old 06-21-2007, 08:15 PM   #2
3point2
LQ Newbie
 
Registered: Jan 2006
Distribution: Slackware 11.0
Posts: 23

Rep: Reputation: 15
Looks like your kernel doesn't have the driver for your network adapter compiled in. If

Code:
$ dmesg | grep eth0
doesn't show anything, you most likely need to manually load the appropriate module into the kernel.
 
Old 06-22-2007, 04:29 AM   #3
aleksanteri
LQ Newbie
 
Registered: Jun 2007
Location: Finland
Distribution: Debian Lenny (Testing)
Posts: 14

Original Poster
Rep: Reputation: 0
[$ dmesg | grep eth0] truly doesn't give anything. I tried to load the module, but I can't find any appropriate networking module in the menuconfig.

Am I doing something wrong in this point?
 
Old 06-22-2007, 11:08 AM   #4
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405
Hi,

Looks indeed like a missing driver. You could try the 'forced' (nvidia) driver.

If you use the 2.6.16.27 kernel that goes with LFS 6.2, you can find it here:
Device Drivers -> Network device support -> Ethernet (10 or 100Mbit) -> EISA, VLB, PCI and on board controllers -> Reverse Engineered nForce Ethernet support (EXPERIMENTAL)

If you use a newer kernel it could be named differently, this is from a 2.6.20.4 kernel:

Device Drivers -> Network device support -> Ethernet (10 or 100Mbit) -> EISA, VLB, PCI and on board controllers -> nForce Ethernet support (NEW).

It is not turned on by default!

Hope this helps.
 
Old 06-22-2007, 04:32 PM   #5
aleksanteri
LQ Newbie
 
Registered: Jun 2007
Location: Finland
Distribution: Debian Lenny (Testing)
Posts: 14

Original Poster
Rep: Reputation: 0
Nice, that does the trick, thanks
 
Old 10-16-2007, 02:38 PM   #6
cgoetz
LQ Newbie
 
Registered: Oct 2004
Location: Brussels
Posts: 6

Rep: Reputation: 0
Slackware 12 & udev

I had issues on Slackware 12 I could not get arround by configuring inet1.conf , modules.conf, loading drivers manually. eth0 was known as eth1 and eth0 did not exist.

Configuring the udev rule as stated here did the trick:

ACTION=="add", SUBSYSTEM=="net", SYSFS{address}=="00:00:00:00:00:00", NAME=="eth0"

Thks

--cgoetz
 
Old 10-26-2007, 05:44 PM   #7
kul292008
LQ Newbie
 
Registered: Sep 2006
Location: india
Distribution: fedora core5
Posts: 1

Rep: Reputation: 0
Thumbs up "Interface eth0 doesn't exist. [ WARN ]"

Great! cgoetz your method is working

Last edited by kul292008; 10-26-2007 at 05:46 PM.
 
Old 10-29-2007, 03:19 PM   #8
dwhitney67
Senior Member
 
Registered: Jun 2006
Location: Maryland
Distribution: Kubuntu, Fedora, RHEL
Posts: 1,541

Rep: Reputation: 335Reputation: 335Reputation: 335Reputation: 335
Help!

I just started running my installation of CLFS (cross-compiled LFS), and I am too having trouble with the network set up. Here's what I have:

Code:
# grep -H . /sys/class/net/*/address
/sys/class/net/eth0/address:00:30:59:02:42:ea
/sys/class/net/lo/address:00:00:00:00:00:00
Code:
# cat /etc/udev/rules.d/26-network.rules
ACTION=="add", SUBSYSTEM=="net", SYSFS{address}=="00:00:00:00:00:00", NAME="eth0"
I've also tried:
Code:
# cat /etc/udev/rules.d/26-network.rules
ACTION=="add", SUBSYSTEM=="net", BUS=="pci", ID=="0000:00:12.0", NAME="eth0"
I have only one ethernet controller, and it is an Intel 8255xER/82551IT Fast Ethernet Controller, which to the best of my knowledge uses the eepro100 kernel driver.

Code:
# lsmod
Module         Size   Used by
af_packet      17160  0
evdev           9472  0
eepro100       28944  0
mii             5504  1 eepro100
Code:
# lspci | grep -i ethernet
00:12.0 Ethernet controller: Intel Corporation 8255xER/82551IT Fast Ethernet Controller (rev 10)
I've tried setting up both static and DHCP (preferred) configurations for the eth0 interface. With the static setup, the interface is brought up, however I am unable to ping anything on my local network. The DHCP fails to even come up.

Here's the configuration for the static IP setup:

Code:
# cat /etc/sysconfig/network-devices/ifconfig.eth0/ipv4
ONBOOT=yes
SERVICE=ipv4-static
IP=192.168.1.107
GATEWAY=192.168.1.1
PREFIX=24
BROADCAST=192.168.1.255
Is there something obvious that I am missing?

Last edited by dwhitney67; 10-29-2007 at 04:03 PM.
 
Old 10-29-2007, 08:37 PM   #9
Seph64
Member
 
Registered: Feb 2003
Distribution: Gentoo, FreeBSD, LFS
Posts: 298
Blog Entries: 21

Rep: Reputation: 30
Quote:
Originally Posted by dwhitney67 View Post
Help!

I just started running my installation of CLFS (cross-compiled LFS), and I am too having trouble with the network set up. Here's what I have:

Code:
# grep -H . /sys/class/net/*/address
/sys/class/net/eth0/address:00:30:59:02:42:ea
/sys/class/net/lo/address:00:00:00:00:00:00
Code:
# cat /etc/udev/rules.d/26-network.rules
ACTION=="add", SUBSYSTEM=="net", SYSFS{address}=="00:00:00:00:00:00", NAME="eth0"
I've also tried:
Code:
# cat /etc/udev/rules.d/26-network.rules
ACTION=="add", SUBSYSTEM=="net", BUS=="pci", ID=="0000:00:12.0", NAME="eth0"
Is there something obvious that I am missing?
Look at your /sys/class/net/*/address

Notice something?

Code:
ACTION=="add", SUBSYSTEM=="net", BUS=="pci", ID=="0000:00:30:59:02:42:ea", NAME=="eth0"
Code:
ACTION=="add", SUBSYSTEM=="net", BUS=="pci", SYSFS{address}=="0000:00:30:59:02:42:ea", NAME=="eth0"
See if one of my alteration works.

Last edited by Seph64; 10-29-2007 at 08:41 PM.
 
Old 10-29-2007, 09:23 PM   #10
dwhitney67
Senior Member
 
Registered: Jun 2006
Location: Maryland
Distribution: Kubuntu, Fedora, RHEL
Posts: 1,541

Rep: Reputation: 335Reputation: 335Reputation: 335Reputation: 335
Seph64 -

Thanks for the suggestions, however I still cannot my system's ethernet to work. Is there perhaps another file that I need to examine (that I have not already listed in my first post)? I want to set up my udev rules' file such that I do not have to hard-code the MAC address. I need to be able to use my distro on a multitude of systems, not just the one I am currently using as a test-bed.

To conclude, I tried both of your suggestions, and still no joy.

Btw, could it a be a kernel configuration issue? I have these options configured as follows:

Code:
CONFIG_NET=y
CONFIG_PACKET=m
CONFIG_UNIX=y
CONFIG_INET=y
CONFIG_IP_FIB_HASH=y
CONFIG_TCP_CONG_BIC=y
...
CONFIG_NETDEVICES=y
CONFIG_DUMMY=m
CONFIG_TUN=m
...
CONFIG_NET_ETHERNET=y
CONFIG_MII=m
...
CONFIG_NET_PCI=y
CONFIG_EEPRO100=m
 
Old 11-07-2007, 12:40 PM   #11
dwhitney67
Senior Member
 
Registered: Jun 2006
Location: Maryland
Distribution: Kubuntu, Fedora, RHEL
Posts: 1,541

Rep: Reputation: 335Reputation: 335Reputation: 335Reputation: 335
I resolved the issue I was having with my system. Apparently the eepro100 is the correct driver to use for my network card when using an earlier kernel (2.4.27), however it is not the appropriate driver when running 2.6.17.13. For the later kernel I had to use the e100 driver.

This revelation came about when I tested my system with Knoppix, thus gleaning from the modules it loaded, as to which was the correct net driver for my system.

Anyhow, all is well now. Thank you everyone for your help.
 
  


Reply

Tags
eth0, network


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"Interface eth0 does not exist" Whitesocks Linux - Networking 2 09-05-2005 04:19 AM
Virtual PC 2004 and VWware Workstation - "interface eth0 [failed]" abijahboaz Linux - Newbie 8 10-16-2004 07:53 PM
"Bringing up interface eth0: failed" on 3com NIC zoinkedzonker Linux - Networking 3 08-17-2004 12:18 AM
rh8.0 boot up stuck on "bringing up interface eth0" tnf Linux - Wireless Networking 7 03-22-2004 07:41 AM
RHL7.3 stops loading at "Bringing interface of eth0" rvijay17 Linux - General 1 10-10-2002 01:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch

All times are GMT -5. The time now is 03:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration