LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices


Reply
  Search this Thread
Old 06-02-2005, 11:19 AM   #1
matthewa
Member
 
Registered: Mar 2005
Distribution: Slackware 10.1
Posts: 123

Rep: Reputation: 15
I cant get into the chroot enviroment...help


ok guys Im on 6.3. Entering the Chroot Environment.

My bash prompt is focused on /mnt/lfs....

When I put in the command:


chroot "$LFS" /tools/bin/env -i \
HOME=/root TERM="$TERM" PS1='\u:\w\$ ' \
PATH=/bin:/usr/bin:/sbin:/usr/sbin:/tools/bin \
/tools/bin/bash --login +h


..as is specified in the beginning of this chapter to enter the chroot enviroment I get this error message:

/tools/bin/bash: error while loading shared libraries: libtermcap.so.2: cannot open shared object file: No such file or directory

Is this a good thing? Is this a bad thing? .....help please! You guys are the masters
 
Old 06-02-2005, 11:30 AM   #2
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
It looks like you didn't set up the environment properly and compiled the things in /tools linked against the libraries on your host system. libtermcap.so.2 is not part of the temporary tools, in fact I don't have it on my system at all.
Try again and this time pay attention to the steps involved in creating and becoming the user lfs
 
Old 06-02-2005, 11:47 AM   #3
matthewa
Member
 
Registered: Mar 2005
Distribution: Slackware 10.1
Posts: 123

Original Poster
Rep: Reputation: 15
Thanks Andrew, but I got it. Just in case anyone else has this problem, here is how you fix it....

While compiling bash in chapter 5, the lfs authors obviously left out something of great importance within the configure stage. You must configure bash with a static link and prefix tools with ncurses, or you aaint gonna go any furthure at this stage in the process. Im not sure if it was done as a typo or if the authors left it out on purpose to get you to think, but Ill bet it was the later.

At any rate, go back and recompile bash using this configure command instead of the one found in chapter 5:

./configure --enable-static-link --prefix=/tools --with-curses --without-bash-malloc

then you will get the output "i have no name!" when you enter the chroot commands given in chapter 6.

Its a simple matter of one linked library not being there! Good one lfs!.....lol, you almost had me on that one
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
sudo /usr/bin/chroot /home/chroot /bin/su - xxx| /bin/su: user xxx does not exist saavik Linux - General 3 07-04-2007 10:30 AM
Now Bash isnt working within the chroot enviroment matthewa Linux From Scratch 2 06-02-2005 06:37 PM
destop enviroment YBA^[x] Linux - General 3 08-10-2004 11:53 AM
best runtime enviroment rh 9 cool hat Linux - Software 8 08-08-2004 10:58 AM
NEW to Linux enviroment NReker Linux - Newbie 9 02-20-2002 12:37 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch

All times are GMT -5. The time now is 12:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration