LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices


Reply
  Search this Thread
Old 05-27-2005, 08:50 AM   #1
channelzero
LQ Newbie
 
Registered: May 2005
Distribution: lfs-svn
Posts: 11

Rep: Reputation: 0
Question How to start Acrobat Reader 7 binary?


Hi,

Iīve tried to use Acrobat Reader 7 binary on my LFS system, installation works fine,
but if i start it, the splash screen comes up and the nothing happens.

There is no error message and the binary has no debug or verbose option,
so i wonder is there a dependency that is not fulfilled?

If anyone has a clue, please post.

cz
 
Old 05-27-2005, 09:30 AM   #2
madluther
Member
 
Registered: Aug 2004
Distribution: LFS
Posts: 350

Rep: Reputation: 31
I run LFS 5.0 at work and Acroread 7.0 works ok on that, I have yet to test it on LFS 6.0 which i run at home. What version of LFS are you running ?

Mad.
 
Old 05-27-2005, 10:31 AM   #3
Harmaa Kettu
Member
 
Registered: Apr 2005
Location: Finland
Posts: 196

Rep: Reputation: 30
It needs libstdc++.so.5 from gcc 3.3.
 
Old 05-27-2005, 02:48 PM   #4
channelzero
LQ Newbie
 
Registered: May 2005
Distribution: lfs-svn
Posts: 11

Original Poster
Rep: Reputation: 0
Lightbulb

Thanks Harmaa Kettu this was very helpful.

Iīve done a symbolic link to libstdc++.so.6 and it worked.

But another prob is appearing, reader canīt find .api modules.

cz
 
Old 05-28-2005, 11:12 PM   #5
kjordan
Member
 
Registered: Jul 2004
Distribution: LFS, I felt the itch and scratched it
Posts: 227

Rep: Reputation: 31
The api modules won't work if you just link libstdc++.so.6 to libstdc++.so.5. You actually need the library from gcc 3.3.x. I was having the same problem and installed gcc 3.3.4 and just used the library from it and it works fine.
 
Old 05-29-2005, 06:57 AM   #6
channelzero
LQ Newbie
 
Registered: May 2005
Distribution: lfs-svn
Posts: 11

Original Poster
Rep: Reputation: 0
Question

So iīve compiled gcc-3.3 without installing it, then i copy
the library's to /usr/lib, and now it does only complain
that PPKlite.api is not loaded.

So i wonder if thereīs a way to make the system backward
compatible, without downgrading. Because some proprietary or
precompiled sw relies on the old libs, i.e. firefox-1.0.4-binary (i know itīs open-source)
it gives me following message when started:

Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 75: _dl_next_tls_modid:
Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!

even though i have libsdtc++.so.5 not installed in /usr/lib but
in firefoxes own dir, thereīre maybe other dependencies, or
ld is not aware of to different versions of the lib.

Some distros have a compatibility package to solve this, maybe
thereīs a way to fix this in LFS too.

cz
 
Old 05-30-2005, 11:16 AM   #7
Harmaa Kettu
Member
 
Registered: Apr 2005
Location: Finland
Posts: 196

Rep: Reputation: 30
Quote:
now it does only complain that PPKlite.api is not loaded.
This one is documented in the Acrobat Reader README file. Easy solution: delete the plugin. It doesn't do anything useful.

Quote:
Inconsistency detected by ld.so: ../sysdeps/generic/dl-tls.c: 75: _dl_next_tls_modid:
Assertion `result <= _rtld_local._dl_tls_max_dtv_idx' failed!
First I thought this was linuxthreads vs. NPTL conflict (tls = Thread Local Storage), but googling revealed it to be NPTL bug instead. There is a patch in Gentoo bugzilla.
 
Old 05-30-2005, 06:46 PM   #8
channelzero
LQ Newbie
 
Registered: May 2005
Distribution: lfs-svn
Posts: 11

Original Poster
Rep: Reputation: 0
Lightbulb

This patch works fantastically well, even if i donīt know what it exactly does.
Got something to do with nvidia driver and the threading lib, if i understand
the bug trackers right?

So i have to say thank you once again, for giving me this hint, i appreciate that.

One little question in this context: iīm using kde with baghira style and gtk-qt-engine
Is firefox a real gtk-app?
When started from bash it gives me lots of errors like this:
(firefox-bin:21634): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion `pixbuf != NULL' failed

But itīs full functional nevertheless.

cz
 
Old 05-31-2005, 05:25 AM   #9
channelzero
LQ Newbie
 
Registered: May 2005
Distribution: lfs-svn
Posts: 11

Original Poster
Rep: Reputation: 0
Ok this errors came from the gtk-qt-engine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
some errors when start Acrobat Reader 7.0 numen Linux - Software 1 12-02-2005 12:40 AM
acrobat reader 7 alaios Debian 4 05-19-2005 10:48 AM
Acrobat Reader unixfreak *BSD 4 07-24-2004 10:15 AM
Acrobat reader 5.06 helenvale Linux - Newbie 10 07-27-2003 05:59 PM
acrobat reader samon Linux - Software 15 02-24-2003 05:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch

All times are GMT -5. The time now is 06:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration