-   Linux From Scratch (
-   -   Help! 2.4.29 + nptl = glibc error: cannot compute (long double), 77 (

Yerp 03-16-2005 12:49 AM

Help! 2.4.29 + nptl = glibc error: cannot compute (long double), 77
Okay, I always cringe at having to use LinuxThreads...bad experience.
I want nptl, but I get hell building it under a 2.4 kernel (I'm not interested in a stable kernel that keeps getting "features added"..if a 2.7 came out, then I'd move to 2.6.)

So, I have two tweaked LFS systems, the one I am installing on, and the one I am installing.
- Kernel 2.4.29
- Glibc-2.3.4-20040701 (LinuxThreads Oh my)

New LFS system
- Kernel 2.4.29
- Glibc-2.3.4 (nptl, hell yeah)
Looking into the the hardened lfs, I found out how i could build the nptl headers and get past my previous issues of glibc never wanting to install from a LinuxThreads system (2.4.29).


Okay, I put that because I am afraid that the nptl may be causing my problem..and other than that my systems are almost identical LFS-ish.

In attempt to install the system I got the following error in my first glibc (not including the glibc header install to get nptl working) under what would otherwise be a stage 5 install.

checking for long double... yes
checking for size of long double... configure: error: cannot compute sizeof (long double), 77

I have tried many twists and turns in configuring both this and all packages before this only to get the same results.

After many changes attemps and whatnots my configure command looks like the following:

PROGRAM=glibc-2.3.4 &&
... && # decompress from archive & change directory commands
LD_LIBRARY_PATH=/tools/lib ../${PROGRAM}/configure --prefix=/tools --disable-profile --enable-add-ons --with-binutils=/tools/bin --with-headers=/tools/include --without-gd --without-cvs

* Any typos in the above are from me falling asleep, code has been quadruple checked for any spelling erros..

I have searched google, mailing list of gentoo, and the entire linux from scratch mailing list archive, from alfs to livecd. All answers only resulted in identical error aboce. Reinstalled a few times from a clean slate to get only consistancy a network technitian could dream for.

Remmis 03-17-2005 11:46 PM

This one kept me up more than a few nights. In fact, I get this exact error anytime I use an existing toolchain to try and build another LFS system. Refer to this and cross your fingers.

darkRoom 03-23-2005 09:12 PM

Theres a few things that you should try, do a sanity check as per the book and post the results.

Put this in a c file


int main(void){printf("foobar\n"); return(0);}
gcc -o test test.c
and run ./test

Note the results of this and also of 'ldd test'

Also in the config.log in glibc-builld you should look for errors and post the relevant sections.

This should prove if the problem is a broken toolchain.

Yerp 03-25-2005 06:28 PM

well as it turns out, at some point a 1 was turned to a 0 and in some other point a zero was turned into a 1.

Resulting in a corrupt tar file for gcc!!!

turns out my backups had the problem too...must have been a cd-rom burn issue? scratch?
anway, thanx to md5checksum and a few minutes of download time and I got past this problem.

goes to show how useful md5 is..

nptl thought eventual gave expected errors later on. But that will be solved, hopefully, when i do some circular installs with glibc and both 2.4 and 2.6 kernel..

All times are GMT -5. The time now is 01:34 PM.