-   Linux From Scratch (
-   -   Gpm not working no mouse pointer no copy & paste (

EDDY1 10-24-2012 02:08 AM

Gpm not working no mouse pointer no copy & paste
Os LFS-7.2 in virtualbox
I installed links it works
I installed gpm & I don't get a mouse pointer at all.
Installed using these instructions.
Dmesg is seeing touchpad as
PS/2 Controller

Keith Hedger 10-24-2012 06:14 AM

Are you running the GPM bootscript? do you need any special touchpad divers enabled in your kernel?

EDDY1 10-24-2012 07:47 AM

I guess I forgot to show the link that I used but yes I did install bootscripts.

I'm really thinking that it's virtualbox itself, I opened another machine & noticed that while it captures keyboard, it doesn't capture mouse. Also I did install VBoxGuestAdditions in other machine.
I can use mouse but not in console.

Keith Hedger 10-24-2012 03:58 PM

Have a look here:

EDDY1 10-25-2012 12:25 AM

I will try to figure out how to ulnload vbga when I get home. Thank you for your input.

EDDY1 10-26-2012 07:35 PM

I tried the link above but it did not work.
I installed gpm to my main host system & it works, but it doesn't work in VB host to lfs, so I"m going to bite the bullet & allocate some space on my hdd to install lfs.
It's quite addicting I feel that I'm learning a lot.

EDDY1 10-27-2012 01:42 PM

I bit the bullet & started a fresh install directly to hdd, it's amazing how much faster the packages are compiling, I'm already at chapter6.9.

EDDY1 10-29-2012 03:07 AM

I bit the bullet like I said in previous post & encountered a few problems in chroot environment.
I couldn't run update-grub, apt-get nor aptitude without encountering error: Command not found.
I obviously screwed-up my bash_profile.
Anyway here are 2 of the 3 errors that I remember

dpkg: warning: 'ldconfig' not found in PATH or not executable.
dpkg: warning: 'start-stop-daemon' not found in PATH or not executable.
dpkg: error: 2 expected programs not found in PATH or not executable.
Somehow during chroot my ldconfig was changed to /mnt/lfs/var.

System was still bootable then, but would not update-grub to boot lfs even though it saw it. trying sudo update-grub saw it but wouldn't write the file after generating grub.cfg.
Since grub wouldn't update I decided to chroot LFS & install grub there. I installed grub & created grub.cfg & rebooted to kernel panic so now I have an unbootable system.
I was however able to repair by booting my debian wheezy usb installation which had my squeeze already in it's grub.

EDDY1 10-29-2012 02:47 PM

After installing lfs to physical partition gpm & links are installed just have to get my wireless running now. Anyway this thread is solved on to the next 1.

I used this to post to get gpm working
After they gave me hint as to getting it started I edited /etc/sysconfig/mice & reinstalled bootscript.

All times are GMT -5. The time now is 11:08 AM.