LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices


Reply
  Search this Thread
Old 11-02-2006, 10:31 AM   #1
bourbonstreet
LQ Newbie
 
Registered: Oct 2006
Location: USA
Distribution: suse 10.0
Posts: 9

Rep: Reputation: 0
gcc configure error


I`m having a bit of a problem with configuring gcc.
After untarring gcc with: "tar jxf gcc-4.0.3.tar.bz2" (no quotes)
i make the build dir with "mkdir -v ../gcc-build"
I then cd to that dir with:" cd ../gcc-build "( all this from within the gcc-4.0.3 dir)
I then run the command from the book:
" ../gcc-4.0.3/configure --prefix=/tools \ --with-local-prefix=/tools --disable-nls --enable-shared \
--enable-languages=c"
Then the problems start. i get 2 warnings( as follows:
configure:warning: --with-local-prefix=/tools: invalid host type
configure:warning: --enable-languages=c: invalid host type
configure: error: can only configure for one host and one target at a time

I`m wondering as i`m using the live cd 6.2-3 as host ,is the "--with-local-prefix=/tools" needed here?The book says its used to remove /usr/local/include from gcc`s include search path.This is not absolutely essential,however ,it helps to minimize the influence of the host system.I`m assuming they mean /usr/local/include from the host system ,is there such on the cd?

thanks


ps...need a scrathing my head smiley.
 
Old 11-02-2006, 10:59 AM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405
Hi,

You probably entered this (one line):

../gcc-4.0.3/configure --prefix=/tools \ --with-local-prefix=/tools --disable-nls --enable-shared \ --enable-languages=c

That is incorrect and not what the book is trying to tell you.

This would be correct (again, one line):

../gcc-4.0.3/configure --prefix=/tools --with-local-prefix=/tools --disable-nls --enable-shared --enable-languages=c

or this:

../gcc-4.0.3/configure --prefix=/tools \
--with-local-prefix=/tools --disable-nls --enable-shared \
--enable-languages=c


Mind you, there are 3 lines! After every \ you go to the next line.
The \ tells the shell that the upcoming enter is to be 'discarded' because the command continues on the next line.

Hope this helps.
 
Old 11-03-2006, 11:50 PM   #3
bourbonstreet
LQ Newbie
 
Registered: Oct 2006
Location: USA
Distribution: suse 10.0
Posts: 9

Original Poster
Rep: Reputation: 0
ah ..got it....see i`ve learned something useful already, thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gcc ./configure error!! HELP nectron101 Linux - Newbie 1 04-09-2006 11:24 PM
Error ./Configure GCC 3.4.4 D1G1T477 Linux - General 1 06-21-2005 11:29 AM
mplayer ./configure gcc error U-Toast Linux - Software 21 08-28-2004 06:06 PM
gcc-3.3.3 compling(configure-target-libiberty error 1) windus Linux - Software 0 04-18-2004 01:38 PM
gcc configure error rl5 Linux From Scratch 2 03-31-2004 10:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch

All times are GMT -5. The time now is 07:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration