-   Linux From Scratch (
-   -   From Dash to Bash (

Zimo 09-22-2012 11:07 AM

From Dash to Bash
Hi guys, i'm new and i'm trying to build LFS using linux mint 12 - Lisa - LXDE. Using i found i have dash instead of bash. I searched online and i've found that dash will be a source of trouble. So my question is: how can i change from dash to bash?

However i have another question: if i type "echo $0" i have " /bin/bash". Is it correct?

Thanks for answers.

spiky0011 09-22-2012 12:12 PM


If the version check test failed then

rm -v /bin/sh

ln -s /bin/bash /bin/sh
You can post the output of version-check if unsure

Zimo 09-22-2012 12:31 PM

This is the output of


+bash, version 4.2.10(1)-release
/bin/sh -> /bin/dash
Binutils: (GNU Binutils for Ubuntu)
bison (GNU Bison) 2.4.1
/usr/bin/yacc -> /usr/bin/bison.yacc
bzip2, Version 1.0.5, 10-Dec-2007.
Coreutils: 8.5
diff (GNU diffutils) 3.0
find (GNU findutils) 4.4.2
GNU Awk 3.1.8
/usr/bin/awk -> /usr/bin/gawk
gcc (Ubuntu/Linaro 4.6.1-9ubuntu3) 4.6.1
(Ubuntu EGLIBC 2.13-20ubuntu5.1) 2.13
grep (GNU grep) 2.9
gzip 1.3.12
Linux version 3.0.0-12-generic (buildd@vernadsky) (gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3) ) #20-Ubuntu SMP Fri Oct 7 14:50:42 UTC 2011
m4 (GNU M4) 1.4.16
GNU Make 3.81
patch 2.6.1
Perl version='5.12.4';
GNU sed version 4.2.1
tar (GNU tar) 1.25 line 30: makeinfo: command not found
xz (XZ Utils) 5.0.0
gcc compilation OK
You can see bin/dash: but when i type echo..


simone-su@netbook ~ $ echo $0

spiky0011 09-22-2012 12:34 PM



echo $SHELL
also you need to fix line 30: makeinfo: command not found

The output of the script shows dash /bin/sh -> /bin/dash

Zimo 09-22-2012 12:36 PM

here it is:


simone-su@netbook ~ $ echo $SHELL

spiky0011 09-22-2012 12:41 PM

Thats interesting, Although i would make the system meet the requirements to be safe. Maybe someone can explain!

Zimo 09-22-2012 12:46 PM

I fixed makeinfo installing texinfo. So i can try to continue with this background?

EDIT: i've tried using version-check on ubuntu 10.04 ( same computer, other partition ) and the result is the same!

spiky0011 09-22-2012 12:50 PM

I would change the dash to bash so the script clears all failures to be on safe side, that is what I would do, unless someone can confirm that it will work. If you leave it You might end up with trouble

Zimo 09-22-2012 12:59 PM

I'm sorry, you mean installing bash or simply changing directory name?

spiky0011 09-22-2012 01:17 PM

Change link as I posted earlier

Zimo 09-23-2012 04:19 AM

Ok! Link, not directory name..thanks. However, maybe i'll try and i'll tell you. I spent time in last days beginning the build, but i stopped just after glibc due to link issues: can these two things be connected?

spiky0011 09-23-2012 04:27 AM

I would start again your not that far in lets get it right from the beginning

Zimo 09-23-2012 04:29 AM

Of course. I erased everything on that partition and start again from the beginning.

Zimo 10-02-2012 01:11 PM

Spiky, it worked.

spiky0011 10-02-2012 01:50 PM


When you say it worked explain???

All times are GMT -5. The time now is 05:57 PM.