-   Linux From Scratch (
-   -   Errors on booting up (

TheMad 02-03-2003 03:01 AM

Errors on booting up
Well, I just finished compiling and installing my LFS 4.0 system and I tried booting into it for the first time and got 3 errors. The first one was easy to fix (I mounted all my other partitions but forgot to create the folders where they were supposed to go).

The next one goes someting like this:

SIOCDELRT: No such process [FAILED]

Then, shortly thereafter, it told me:

eth0: unknown interface: No such device [FAILED]

Now, I know that my network card works as I'm using it right not to type this. I'm just curious. Is there some way to use Slackware's netconfig program in LFS. I've tried copying the binaries over, but that doesn't really help.

If thats not an option, is there some other way to make it recognize my network card? And what is SIOCDELRT?

One other question I've got. Where does LFS keep its equivelant of /etc/rc.d/rc.modules/?

*edit* Oh, and one last question. I tried doing adduser as root but it didn't recognize the command. Is this normal or does it mean I've got deeper problems than just not getting online?

*edit #2* One last question (I promise!). Now that I've installed LFS is it ok to delete /static/?


PTBmilo 02-04-2003 02:03 AM

well, Congrats on getting this far... the battle is over, now the fun begins!


This is telling you that the kernel has a problem w/ your network card (as you said). You are going to re-compile your kernel and either build the driver into the kernel, or as a module. What card do you have, or better yet, do you know the module that you are using in slack? (you might be able to check out /etc/modules.conf and get it)

cd /usr/src/linux
make menuconfig #This is where you can configure it all
make dep
make bzImage
make modules
make modules_install

2) no, LFS doesn't have the rc.modules. If you have looked at the rc.d tree, you'll notice that all of the bootup files are in /etc/rc.d/init.d and they are linked to from /etc/rc.d/rc[0-6].d.

If you want to add some modules, you are going to need to edit the existing scripts, or write your own (from scratch, remember :). I would suggeest just compiling a lot of stuff into the kernel at first so you don't have to deal with modules that much. After that, you can read up on using modules and then play around with them.

3) it's 'useradd', you had it backwards... I always thought it should be your way too though ;-)

4) You can definitly delete it, or you can tar & bzip2 it up so that you can use it later (if you REALLY fsck up your system) so that you don't have to go through that whole first step again.

Well, have fun!


I just checked out the adduser program that is on my slack box, it's just a shell script. You can probably copy it over to your LFS partition and use it just fine.

TheMad 02-04-2003 04:50 PM

Ah, many thanks for the help.


All times are GMT -5. The time now is 11:16 PM.