-   Linux From Scratch (
-   -   error using lfs while compiling lfs book's 6.12 (gcc-4.1.2) section (

aditya_gpch 04-19-2008 02:34 AM

error using lfs while compiling lfs book's 6.12 (gcc-4.1.2) section
i am compiling the gcc-4.1.2 and having the following eror every time
gawk -f ../../gcc-4.1.2/gcc/opt-gather.awk ../../gcc-4.1.2/gcc/c.opt ../../gcc-4.1.2/gcc/common.opt ../../gcc-4.1.2/gcc/config/i386/i386.opt > tmp-optionlist
/bin/sh ../../gcc-4.1.2/gcc/../move-if-change tmp-optionlist optionlist
optionlist is unchanged
echo timestamp > s-options
HEADERS="auto-host.h ansidecl.h" DEFINES="" \
/bin/sh ../../gcc-4.1.2/gcc/ bconfig.h
bconfig.h is unchanged
make[2]: *** No rule to make target `../../build-i686-pc-linux-gnu/libiberty/libiberty.a', needed by `build/genmodes'. Stop.
make[2]: Leaving directory `/mnt/phoenics/gcc-build/gcc'
make[1]: *** [all-gcc] Error 2
make[1]: Leaving directory `/mnt/phoenics/gcc-build'
make: *** [all] Error 2

if somebdy have idea or resource to make a clean make plz tell me i am waitin for reply.
thanx for ur help

//Moderator note: Please post your thread in only one forum. Posting a single thread in the most relevant forum will make it easier for members to help you and will keep the discussion in one place. Do not post duplicate threads again. Read the LQ Rules before continuing.

Agrouf 04-21-2008 03:19 AM

Is this the top most error?
How did you ./configure it?
did you copy the complete gcc sources? Is the libiberty directory present?

phoenix12345 04-23-2008 08:59 AM

I'm getting the same error when i try to make gcc. Libiberty folder is present in my build directory. And i configured it using CC="gcc -B /usr/bin/" ../gcc-4.1.2/configure --prefix=/tools --with-local-prefix=/tools --disable-nls --enable-shared --enable-languages=c
Last time i tryed to compile it make(in the source folder) worked just fine.

knudfl 04-24-2008 04:23 PM

This error will happen if you are re-using the files, make clean will not do it.
So make a new directory with a new name and start with 'tar jxvf ... again, else the risk of an error.
And of course follow 6.12.1 step by step.

All times are GMT -5. The time now is 10:46 PM.