-   Linux From Scratch (
-   -   error / report with eth0 link (

spiky0011 12-30-2011 11:24 AM

error / report with eth0 link

I have my LFS running just nice at the moment, There are a few little niggles, I get an error/report just as I log in,

r8169 000000:05:00.0 eth0: link up
ADDRCONF(NETDEV_CHANGE) eth0: link becomes ready

I found some web pages here
The 1 above mentions

The other fix is to do Bruce's fix and also add -g to the second NTPD

and here
the 2nd link mentions putting sleep 3 at the end of start /etc/rc.d/init/network
When I looked at file I was unsure where to put it exactly.

The wired (eth0) is working fine I would just like to tide it up abit.

druuna 12-30-2011 11:43 AM


And a third "fix":

This message is sent to the terminal by klogd. I personally don't like the default log level that is used by klogd. Changing it to a different log level is done by the -c flag (see man klogd).

I have the following line in my /etc/rc.d/init.d/sysklogd file:

start_daemon /sbin/klogd -c 3
The above will get rid of that message and all other messages that have log level 3 or higher.

I made it a habit to:
a) not to add the -c part until a week or so after a fresh install. Just in case a new one pops up,
b) regularly check my log files (which one should do anyway....).

T address the specific issue: I don't think there is a solution, I've also looked for this and couldn't find one. It is not LFS specific, I also see this on Debian Squeeze and RHEL 6.0/1

I'm using 2 Marvel 88E8056 PCI-E Gigabit cards, so it doesn't seem to be limited to the Intel (82566MM/82573L) Gigabit cards mentioned in the links you posted.

Hope this helps.

spiky0011 12-30-2011 12:07 PM

Thks druuna worked a treat, I have a few more little niggles to sort out,
Maybe you can help with but thats another thread.

All times are GMT -5. The time now is 02:49 AM.