LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices


Reply
  Search this Thread
Old 11-09-2006, 12:16 AM   #1
giri616
LQ Newbie
 
Registered: Nov 2006
Posts: 2

Rep: Reputation: 0
Unhappy Error during installing glibc-2.2.5


Error during installing glibc-2.2.5 as follow:
loading cache ./config_cache
checking for a BSD compatible install... /usr/bin/install -c
checking whether ln -s works... yes
checking for pwd... /bin/pwd
checking build system type... i686-pc-linux-gnu
checking for gcc... gcc
checking version of gcc... 4.0.0, bad
checking for gnumake... no
checking for gmake... gmake
checking version of gmake... 3.80, ok
configure: error:
*** These critical programs are missing or too old:gcc
*** Check the INSTALL file for required versions.


Wanted to make a cross-compiler am stuck here plz help
 
Old 11-09-2006, 01:58 AM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405Reputation: 2405
Hi,

Please give a bit more information:

- Are you trying to install LFS / CLFS and which version (I would assume CLFS)?
- What are you using as base system, if it is not the LFS liveCD does it conform to the Host System Requirements as stated in the book?

It looks like you are using a base that is not correct (based on: These critical programs are missing or too old:gcc).
 
Old 11-09-2006, 12:05 PM   #3
Oliv'
Senior Member
 
Registered: Jan 2004
Location: Montpellier (France)
Distribution: Gentoo
Posts: 1,014

Rep: Reputation: 36
Hello,

Well that's quite simple: glibc-2.2.5 is nearly 5 years old and gcc-4.0 is quite recent so either downgrade gcc or upgrade glibc to 2.5

Oliv'
 
Old 11-09-2006, 11:34 PM   #4
giri616
LQ Newbie
 
Registered: Nov 2006
Posts: 2

Original Poster
Rep: Reputation: 0
Problem solved

Thank you guys
it was the problem as gcc4.00 is quit new and the script of glib2.2.5 the max allowd was only till 3.5 or so when they mentioned gcc2.95 or later i thougtht 4.00. should make it work ,
used gcc- 3.2.3 and it has wrked
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem installing glibc-2.3.2-4.80.i686, glibc-common-2.3.2-4.80.8.i386.rpm martianpackets Red Hat 8 05-01-2009 03:22 PM
Installing Glibc 2.3 HELP PLEASE! NLR Linux - Software 22 12-08-2006 01:49 PM
error while installing glibc 2.3.5 chirag_jog Linux - Software 1 10-16-2005 06:31 AM
error installing glibc on slack moschi Linux - Software 2 10-22-2004 11:46 PM
Get this error message: "filesystem is needed by glibc-2.3.2-92" When installing??? Qwirt Linux - Software 1 07-28-2004 06:00 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch

All times are GMT -5. The time now is 05:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration