LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices


Reply
  Search this Thread
Old 06-18-2009, 04:45 PM   #1
ieatsplaydoh
Member
 
Registered: Oct 2006
Location: Denver
Distribution: All of them
Posts: 62

Rep: Reputation: 15
Error as I try to configure Perl


I am building LFS 6.4
When I try to configure perl, I get this error:
Code:
lfs@sam-desktop:/media/disk/sources/perl-5.10.0$ sh Configure -des -Dprefix=/tools -Dstatic_ext='Data/Dumper Fcntl IO POSIX'
sh: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory
I get the same error every time I run 'bash' and when I run 'sh' (but those two are linked)
Thanks
 
Old 06-18-2009, 06:45 PM   #2
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware 14.2
Posts: 2,815
Blog Entries: 1

Rep: Reputation: 261Reputation: 261Reputation: 261
Did you go back and verify that your ncurses install in section 5.14 was successful?
 
Old 06-18-2009, 07:43 PM   #3
ieatsplaydoh
Member
 
Registered: Oct 2006
Location: Denver
Distribution: All of them
Posts: 62

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by weibullguy View Post
Did you go back and verify that your ncurses install in section 5.14 was successful?
Yeah. The library is in /lib and I linked /usr/lib/libncurses.so.5 to it.
I think it is a problem with bash, because it does this when any user runs the bash executable I compiled for LFS. I think I messed up somewhere, and I am going to start from scratch on my Slackware partition. Thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
checking for XML::Parser... configure: error: XML::Parser perl module is required for kornerr Linux - General 11 11-16-2008 08:24 AM
configure error: configure: error: cannot execute: /usr/local/bin/arm-apple-darwin-ld GunNam Linux - General 0 10-24-2008 09:26 PM
dpkg-buildpackage configure: error: can only configure for one host and one target at donnied Debian 0 05-26-2008 08:08 PM
Gtkpod - configure: error: XML::Parser perl module is required for intltool lazyboy994 Linux - Software 6 03-20-2008 10:17 PM
Yum error: .conflict between perl and perl-NDBM_File zepplin611 Red Hat 3 10-20-2004 11:22 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch

All times are GMT -5. The time now is 05:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration