-   Linux From Scratch (
-   -   custom boot cd fails to boot with "Kernel panic - not syncing : vfs" (

ramachandra_ankireddy 11-20-2008 05:21 AM

custom boot cd fails to boot with "Kernel panic - not syncing : vfs"
I created a custom boot CD for RHEL 5 xen kernel (2.6.18-53.el5xen).
I created a customised initramfs image as gzipped compressed cpio image.
I am using isolinux boot loader. My isolinux.cfg looks like this.I am using the same kernel image that came with RHEL 5.

timeout 10
default 1
prompt 1

label 1
kernel mboot.c32
append xen.gz dom0_mem=256M mem=1G noacpi --- vmlinuz console=tty0 load_ramdisk=1 prompt_ramdisk=0 ramdisk_blocksize=1024 ramdisk_size=256M root=/dev/ram init=/linuxrc --- initrd.img noexec=off rw

I am trying to boot a VMWare guest with this boot cd image. It fails with the following error message.
No file system could mount root, tried: ext2 iso9660
kernel panic - not syncing : VFS: Unable to mount root fs on unknown- block(1,0).
I tried to use the initrd image that came with the RHEL 5 distribution. Looks like It works. I created the initrd image with the following command.
find . | cpio -o -c -H newc | gzip -9 > ../initramfs.igz

Can any one explain what could be the mistake in my approach.

kevinalm 11-23-2008 05:10 PM

That error message is typical for a kernel compiled with the root fs type being compiled as a module, and that module not being included in the initrd. Basically, the kernel doesn't know how to read the filesystem on the root partition, and can't get to it's module to do so, because you didn't put it on the initrd.

All times are GMT -5. The time now is 12:45 AM.