LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices


Reply
  Search this Thread
Old 09-08-2002, 06:49 AM   #1
safrout
Member
 
Registered: Mar 2002
Location: egypt
Distribution: Gentoo
Posts: 457

Rep: Reputation: 30
./configure no such file or directory


this will be my first problem with lfs

hope i pass it quickly :

when trying to install bash in chapter 5.5

i get the following wroor msg

lfs@linux:/mnt/lfs> ./configure --enable-static-link --prefix=/mnt/lfs/usr --bindir=/mnt/lfs/bin --with-curses && make && make install && cd /mnt/lfs/bin && ln -sf bash sh
bash: ./configure: No such file or directory
lfs@linux:/mnt/lfs>


although i checked that i have the file sh under /mnt/lfs/bin

can anyone help me plz

Last edited by safrout; 09-08-2002 at 07:20 AM.
 
Old 09-08-2002, 06:57 AM   #2
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 69
make sure you are in the directory. An 'ls' command will show you quickly if you have a configure script that you can actually execute, and will also tell you if you are in the directory.

Cool
 
Old 09-08-2002, 07:03 AM   #3
safrout
Member
 
Registered: Mar 2002
Location: egypt
Distribution: Gentoo
Posts: 457

Original Poster
Rep: Reputation: 30
i am

i am in the directory if u mean /mnt/lfs

andther is no problem about sh file
the problem is about ./configure as u may see

it is saying no such file or directory ???
 
Old 09-08-2002, 07:08 AM   #4
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 69
Right, so you might not be in the correct directory. /mnt/lfs but then the further directory where the configure script is located. So maybe /mnt/lfs/bash-2.5/
would be the directory you need to be in. When you type 'ls' do you see your configure script?
 
Old 09-08-2002, 07:12 AM   #5
safrout
Member
 
Registered: Mar 2002
Location: egypt
Distribution: Gentoo
Posts: 457

Original Poster
Rep: Reputation: 30
hey

what si the configure script ?

and tere is no dir called bash and there is no talking in the book 3.3 about goiing into that dir
 
Old 09-08-2002, 07:20 AM   #6
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 69
There is some things in the book that are 'assumed'. When you configure anything you have to be in the untarred directory. You will have to download the files they provide to you:
http://www.linuxfromscratch.org/view.../packages.html

You need to get those packages, and "untar" them using the commands provided in the section for that. Something like "bzcat filename.tar.bz2 | tar xv" would be one way. Then once they are untarred, you will do each of the install commands in each of the respective directories. So for bash, you will need to 'cd /mnt/lfs/bash-2.05a' before proceeding with the install directions.

Also, a configure script is usually just called 'configure'. It's a script that makes checks, and sends the results (usually) to a makefile, and so forth. So if you see a file called 'configure' and are in the correct directory, then you are probably ok to continue. Think of each package you install as any program that you might install on a regular basis. You have to download the file, untar it somehow, enter the directory, and run certain things to get it installed (usually ./configure make make install).

HTH

Cool
 
Old 09-08-2002, 07:24 AM   #7
safrout
Member
 
Registered: Mar 2002
Location: egypt
Distribution: Gentoo
Posts: 457

Original Poster
Rep: Reputation: 30
Talking ok

so the whole problem that i need to be in the dir of bash itself

what silly i am


thanx for help my friend

and hope i don't do stupid problems like this one again
 
Old 09-08-2002, 07:26 AM   #8
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 69
Hey, no problem. I did pretty close to the same thing a couple of times when I did my first LFS install. Sometimes it's the little things that screw us up.

Good luck

Cool
 
Old 09-06-2005, 05:11 PM   #9
kleam
LQ Newbie
 
Registered: Sep 2005
Posts: 2

Rep: Reputation: 0
ok, so i am trying to .configure something too, but im having a bad problem. the program says im jsut suppose to $ ./configure --prefix=PREFIX.

i started off by typing in

[admin@localhost ~]$ ./configure --prefix=/home/admin/apache2
and recived
bash: ./configure: No such file or directory

the place i untarred the stuff is /home/admin/httpd.2.0.54/
and i want it to be all installed and stuff into /home/admin/apache2

so after reviewing this thread i tried
[admin@localhost ~]$ /home/admin> ./configure --prefix=/home/admin/apache2
and recived
bash: /home/admin: is a directory

i thought i was done so i continued with the walkthrough by using the "make" command
when i did that i recived
make: *** No targets specified and no makefile found. Stop.

(its very discouraging when a computer tells you to stop)

i then tried
[admin@localhost ~]$ /home/adminhttpd-2.0.54> ./configure --prefix=/home/admin/apache2
and still got the same as i did with out the httpd.

i really have no clue why i have to configure.

this is the website i was using:
http://httpd.apache.org/docs/2.0/install.html

any help would be great... thanks


-Kleam


P.S. im very VERY new to linux, so i most likely wont understand what you are talking about if you refer to something most linux users know about. but im really good with windows
 
Old 09-09-2005, 08:41 AM   #10
shevegen
Member
 
Registered: May 2004
Distribution: Slackware / GoboLinux / LFS / VoidLinux
Posts: 133

Rep: Reputation: 26
I am not sure if your question is LFS related, but at any rate:


"(its very discouraging when a computer tells you to stop)"
It "told" you to stop because it knew of no rules. The (auto)configure
script will check for installed stuff on your PC, and considers your
CPU etc... other host settings afaik, then create a script which you can
use with "make" and "make install" after you did run a ./configure.

Have you had a look at the install file in the apache package btw?
 
Old 09-09-2005, 09:44 AM   #11
hoes
Member
 
Registered: Sep 2005
Distribution: debian, linux from scratch
Posts: 185

Rep: Reputation: 50
I think the main problem is that you don't really seem to understand how to run commands.
Some Info:
If you want to run a configure-script, make sure you are in the same directory as the script and type: ./configure --prefix=/home ......

If you are not in the same directory run it like: /home/admin/httpd.2.0.54/configure .......
or httpd.2.0.54/configure ..........
The first commands is the exact path and the second one is the relative path and it assumes that configure in the directory httpd.2.0.54 in your current working directory.
But when you run a configure-script, files will be created in the directory where the script is run from. So if you run /home/admin/httpd.2.0.54/configure in /home/admin a lot of files will be created in /home/admin belonging to the httpd-package.

If I see your commands it looks like you type wrong commands in the wrong directory:
[admin@localhost ~]$ ./configure --prefix=/home/admin/apache2
Here you run ./configure from /home/admin (The ~ stands for your home-directory and this field will always show your current directory)
So in this case you are in the wrong directory.
You ought to be in /home/admin/httpd.2.0.54 to run this command

Next one:
[admin@localhost ~]$ /home/admin> ./configure --prefix=/home/admin/apache2
First of all this command is typed wrong, I think you mean:
/home/admin/configure --prefix=/home/admin/apache2
And then the commands is still wrong because configure is in /home/admin/httpd.2.0.54 instead of in /home/admin
(Also note: that this would have created files in /home/admin, I don't think that's what you want)

And the third One:
[admin@localhost ~]$ /home/adminhttpd-2.0.54> ./configure --prefix=/home/admin/apache2
This one is also spelled wrong. You mean this:
/home/adminhttpd-2.0.54/configure --prefix=/home/admin/apache2
This command should work, but will create files in /home/admin

The think you really want to do is go to /home/admin/httpd.2.0.54
and run ./configure .............. int that directory.

If you have run ./configure successfully a Makefile is created, usually named Makefile.
The make command searches for this file and than runs it, or a part of it.
When you got the error:
make: *** No targets specified and no makefile found. Stop.

That file was not found because the configure-script was not run and therefore there wasn't any makefile.

One last thing about your environment that might be useful to know:
You can run programs by giving there absolute path and name:
/home/admin/httpd.2.0.54/configure
You can also type a relative path:
httpd.2.0.54/configure
letting your computer assume configure in the directory httpd.2.0.54 in your current directory should be run.
But there is also a more common way to run a program:
Just type only the name of the program, for example:
make
When this happens your computer searches the directories in the $PATH-variable.
Just for fun run:
echo $PATH
Now you will get a list of all the directories that are searched to find a program.
The directories will be searched in the sequence that they are printed.
If you want to run a program in the directory you currently are you need type:
./configure
This indicates that configure in the local directory should be run.
If you omit ./ than your computer will search for configure in all the directories listed in $PATH.
Keep this in mind when working with the command-line because it's quite essential.

I hope you can do something with this heap of text.
Good luck
 
Old 09-10-2005, 06:00 PM   #12
kleam
LQ Newbie
 
Registered: Sep 2005
Posts: 2

Rep: Reputation: 0
THANK YOU, i really had no clue what i was suppose to do.... THANKYOU SOOOOOOOO MUCH, uh i was sooo stumped! thankyou
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
bash: <command name> command not found smash Programming 5 03-13-2006 08:48 AM
No /.configure command not found ? RH9, FC1 N A. Osborne Linux - Newbie 1 03-14-2005 11:54 AM
qt-mt not found error during configure Boomba Linux - Software 4 02-15-2005 04:06 PM
Configure error: QT not found marsonist Linux - Software 3 04-26-2004 12:48 AM
'configure' command not found invinciblemk Linux - Newbie 4 02-02-2004 04:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch

All times are GMT -5. The time now is 09:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration