-   Linux From Scratch (
-   -   CLFS ch10.43: module-init-tools-3.4 testing fails - "Unknown endian" (

Bolts 04-08-2009 01:10 AM

CLFS ch10.43: module-init-tools-3.4 testing fails - "Unknown endian"

Host system: Ubuntu x64 (jaunty)
Cross-compile tools built with gcc-3.4
Deviations: bzip2-1.0.5 used in lieu of 1.0.4
chrooted into temporary system

When performing the tests as per the instructions, the testing fails and the following is returned:

make check-TESTS
make[1]: Entering directory `/sources/module-init-tools-3.4'
Building with --enable-zlib...
Testing with --enable-zlib...
Unknown endian!
FAIL: tests/runtests
1 of 1 tests failed
make[1]: *** [check-TESTS] Error 1
make[1]: Leaving directory `/sources/module-init-tools-3.4'
make: *** [check-am] Error 2

This is the portion of tests/runtests that is causing the failure. Lines 60-65:

    # Create endianness links
    case `file modprobe` in
        *MSB*) ENDIAN=be;;
        *LSB*) ENDIAN=le;;
        *) echo Unknown endian! >&2; exit 1;;

I ran 'file modprobe', and it returned:
modprobe: ERROR: Cannot allocate memory for note (Cannot allocate memory)

Why is it unable to determine my system's endianness, and how can I fix it?

Thanks in advance.

Ran 'file modprobe.*' and received the following:
modprobe.o: ELF 64-bit LSB relocatable, x86-64, version 1 (SYSV), not stripped

Changed line 61 from 'case 'file modprobe' in' to 'case 'file modprobe.o' in'.
The test passed after making this change.

archtoad6 10-29-2010 04:04 AM

Thanks for posting the solution. That's the LQ spirit.

A suggestion for the future: If you answer your own question, put the solution in a separate post; this does 2 good things:
  • It generates e-mail to anyone who subscribed to either the thread or the forum.
  • It avoids the creation of oxymoronic 0-reply solved threads.

All times are GMT -5. The time now is 03:18 AM.