-   Linux From Scratch (
-   -   chroot cannot change the root directory (

alkaff 05-05-2008 02:29 PM

chroot cannot change the root directory with LFS live CD
root [ ~ ]# chroot "$LFS" /tools/bin/env -i HOME=/root TERM="$TERM" PS1='\u:\w\$PATH=/bin:/usr/bin:/sbin:/usr/sbin:/tools/bin/mnt/lfs/tools/bin/bash --login +h

and it says:
chroot cannot change the root directory to /tools/bin/env: no such file or directory

Findus 05-05-2008 04:29 PM

I am sorry if this sounds too stupid, but have you checked to see if /tools/bin/env actually exists? If not it may be part of a step you have missed.

On the other hand, I may be completely wrong. It is a long time since I tried to build an LFS system (and gave up on it halv way), and this may be a more serious error, but I remember several times when I had to backtrace my steps to actually do a step I was sure I had done a long time ago.

- Findus

alkaff 05-06-2008 02:51 PM

i tried that before that say error while loding shared object

vadkutya 05-11-2008 04:31 PM

chroot should change the root directory to $LFS and then set up the enviroment with /tools/bin/env (i suppose) and not to /tools/bin/env. your problem is with the variable, so check:

echo $LFS
it should be set to /mnt/lfs


All times are GMT -5. The time now is 10:52 PM.