LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices


Reply
  Search this Thread
Old 06-04-2006, 07:50 PM   #1
nykey
Member
 
Registered: Nov 2003
Posts: 360

Rep: Reputation: 30
checking system version (for dynamic loading) = ERROR


Code:
lfs:/mnt/lfs/sources/tcl8.4.9/unix$ ./configure --prefix=/tools
loading cache ./config.cache
checking whether to use symlinks for manpages... no
checking whether to compress the manpages... no
checking whether to add a package name suffix for the manpages... no
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for building with threads... no (default)
checking if the compiler understands -pipe... yes
checking how to run the C preprocessor... gcc -pipe -E
checking for sin... no
checking for main in -lieee... yes
checking for main in -linet... no
checking for net/errno.h... no
checking for connect... yes
checking for gethostbyname... yes
checking how to build libraries... shared
checking for ranlib... ranlib
checking if 64bit support is requested... no
checking if 64bit Sparc VIS support is requested... no
checking system version (for dynamic loading)... ./configure: line 7338: syntax error near unexpected token `)'
./configure: line 7338: `       OSF*)'
lfs:/mnt/lfs/sources/tcl8.4.9/unix$
I get this error when trying to do ./configure for tcl for running the test suites for GCC and Binutils. I don't know and don't understand what's the problem.
 
Old 06-04-2006, 08:16 PM   #2
nykey
Member
 
Registered: Nov 2003
Posts: 360

Original Poster
Rep: Reputation: 30
Ok so I run the SPECFILE command exactly as in the book ( as user "lfs" and user "root" )and when I do
Code:
root@nykey:~# cat `gcc --print-file specs` | grep ld-linux.so.2
%{!dynamic-linker:-dynamic-linker /tools/lib/ld-linux.so.2}}    %{static:-static}}}
( I'm root here ) the path is right /tools/lib/ld-linux.so.2 but when I do
Code:
lfs:~$ cat `gcc --print-file specs` | grep ld-linux.so.2
%{!static:--eh-frame-hdr} -m elf_i386 %{shared:-shared}   %{!shared:     %{!ibcs:       %{!static:      %{rdynamic:-export-dynamic}     %{!dynamic-linker:-dynamic-linker /lib/ld-linux.so.2}}        %{static:-static}}}
(I'm user lfs here ) I get an incorrect path !!! I think this is my error, how can I fix it ? I tried to modify manually the file /usr/lib/gcc/i486-slackware-linux/3.4.6/specs and I got the same result, as root OK as lfs NOT OK. so ?
 
Old 06-05-2006, 06:35 PM   #3
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
Quote:
`/tools/lib/gcc/i686-pc-linux-gnu/3.4.3/../../../../i686-pc-linux-gnu/bin/as': No such file or directory
why is it trying to access /tools/lib? Chap 6 is supposed to be done in LFS environment, no? It looks like some of your environment variable might have been corrupted during the initial compile in Chap 5.

regards,
...drkstr
 
Old 06-05-2006, 08:18 PM   #4
nykey
Member
 
Registered: Nov 2003
Posts: 360

Original Poster
Rep: Reputation: 30
Well, I tried again on my Slackware-current host. In chapter 5 when trying to build TCL I get the error above, meaning:
Quote:
lfs:/mnt/lfs/sources/tcl8.4.9/unix$ ./configure --prefix=/tools
loading cache ./config.cache
checking whether to use symlinks for manpages... no
checking whether to compress the manpages... no
checking whether to add a package name suffix for the manpages... no
checking for gcc... gcc
checking whether the C compiler (gcc ) works... yes
checking whether the C compiler (gcc ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for building with threads... no (default)
checking if the compiler understands -pipe... yes
checking how to run the C preprocessor... gcc -pipe -E
checking for sin... no
checking for main in -lieee... yes
checking for main in -linet... no
checking for net/errno.h... no
checking for connect... yes
checking for gethostbyname... yes
checking how to build libraries... shared
checking for ranlib... ranlib
checking if 64bit support is requested... no
checking if 64bit Sparc VIS support is requested... no
checking system version (for dynamic loading)... ./configure: line 7338: syntax error near unexpected token `)'
./configure: line 7338: ` OSF*)'
lfs:/mnt/lfs/sources/tcl8.4.9/unix$
What does this mean ? Know how to make this work ?
 
Old 06-05-2006, 08:27 PM   #5
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
What's your kernel version?

maybe this will help:
http://www.linuxfromscratch.org/lfs/errata/6.1.1/
regards,
...drkstr
 
Old 06-05-2006, 09:06 PM   #6
nykey
Member
 
Registered: Nov 2003
Posts: 360

Original Poster
Rep: Reputation: 30
I'm using 2.6.16.19 kernel. Possibly this is my problem. How should I apply the patch, same options like the other ?patch -Np1 -i ../EXAMPLE.patch and do I have to do it in all the passes or just the first time ? I will have to remove the directory after Pass 1, when I unpack it again for Pass 2 should I apply the patch again before starting to configure ?

Last edited by nykey; 06-05-2006 at 09:29 PM.
 
Old 06-05-2006, 10:42 PM   #7
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
Yes, you patch it just like normal. I don't think there are any extra options you need. You will need to apply the patch any time you compile gcc-3.4.3 with that kernel version.

regards,
...drkstr
 
Old 06-06-2006, 12:44 AM   #8
nykey
Member
 
Registered: Nov 2003
Posts: 360

Original Poster
Rep: Reputation: 30
Thank you very much drkstr, looks like I passed all the errors I got untill now using my Slackware host with your help. Just typed make install for glibc in chroot , hope everything will go ok from now on too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
error loading dynamic library with Java trutnev Programming 4 06-01-2005 03:33 PM
system crashes, checking filesystems error iclinux Linux - Newbie 1 01-21-2005 02:42 AM
Need Help Loading Windows XP & SuSe Linux version 8.2---to Make a Dual Boot System Howerton Linux - Newbie 7 09-23-2004 02:49 PM
Can't connect to X11 window server Checking operating system version: must be redha pmarino Linux - General 2 09-20-2004 04:18 PM
error loading operating system (lilo error) KoKi Slackware 1 03-03-2004 04:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch

All times are GMT -5. The time now is 04:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration