-   Linux From Scratch (
-   -   Cannot run 64-bit pre-compiled binaries on CLFS-Pure64 system (

corbis_demon 09-15-2012 05:36 AM

Cannot run 64-bit pre-compiled binaries on CLFS-Pure64 system
I'm trying to install OpenJDK on my CLFS x86_64-64 build, and when I try to run java from the 64bit binary package (OpenJDK- in the latest SVN) that BLFS provides, I get:

sudo: unable to execute /opt/OpenJDK- No such file or directory
At first I thought it was probably a PATH error, but even trying to run the java executable from the host directory gave me the same error. Then I thought perhaps it was a permissions problem, but running it as root gave the exact same error. I then downloaded the JRE bin package from Oracle, and got the same error. So to see if other precompiled binaries failed in the same way, I tried to run the 64-bit dropbox executable, and got the same dreaded error. Googling this got me nowhere. So I really want to know what's going on here. It will be great if somebody could provide some insight on this. Thank you.

smallpond 09-18-2012 04:58 PM

Anything in the messages log?
Is selinux enabled?
What does this give:

ls -l /opt/OpenJDK-

corbis_demon 09-19-2012 02:07 AM

I got it sorted. It's quite embarrassing actually. I just needed to symlink /lib64 and /usr/lib64 to /lib and /usr/lib resp. (since in pure64 CLFS, these aren't present). Thank you, smallpond, for your reply, though. Thanks.

All times are GMT -5. The time now is 11:09 AM.